summaryrefslogtreecommitdiff
path: root/python-opsramp-analytics-utils.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-10 06:08:20 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-10 06:08:20 +0000
commitbf2a215fe411e8138a0559018b8a29fa666ed0fa (patch)
tree046035c57e12bc4faea4bae1f303b51b96c0a23f /python-opsramp-analytics-utils.spec
parentb0594ba72a88388cfb946110b98154f79e67be0d (diff)
automatic import of python-opsramp-analytics-utils
Diffstat (limited to 'python-opsramp-analytics-utils.spec')
-rw-r--r--python-opsramp-analytics-utils.spec157
1 files changed, 157 insertions, 0 deletions
diff --git a/python-opsramp-analytics-utils.spec b/python-opsramp-analytics-utils.spec
new file mode 100644
index 0000000..29915a8
--- /dev/null
+++ b/python-opsramp-analytics-utils.spec
@@ -0,0 +1,157 @@
+%global _empty_manifest_terminate_build 0
+Name: python-opsramp-analytics-utils
+Version: 3.3.1
+Release: 1
+Summary: OpsRamp Analytics SDK
+License: MIT License
+URL: https://github.com/opsramp/analytics-sdk
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/36/6c4078962359edfc20f7c927a7fd851f0b5c6296dc17d65a8dd2b20255ce/opsramp-analytics-utils-3.3.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-Werkzeug
+Requires: python3-boto3
+Requires: python3-botocore
+Requires: python3-dash
+Requires: python3-openpyxl
+Requires: python3-pyjwt
+Requires: python3-requests
+
+%description
+## OpsRamp Analytics Utilities
+
+This is the SDK for writing OpsRamp analytics apps. It is based on [dash](https://plotly.com/dash/), and it has a number of utility functions.
+
+It contains [analysis wrapper project](https://github.com/opsramp/analysis-wrapper).
+
+It is published on [Pypi](https://pypi.org/project/opsramp-analytics-utils/)
+
+#### How to publish on Pypi
+
+After make updates on SDK, modify the version in _setup.py_.
+
+```
+python setup.py sdist bdist_wheel
+python -m twine upload dist/*
+
+Note: if above command not works, then use below command
+python -m twine upload --skip-existing dist/*
+```
+
+- To upgrade the sdk for your app
+```
+pip install --no-cache-dir --upgrade opsramp-analytics-utils
+```
+
+
+
+
+%package -n python3-opsramp-analytics-utils
+Summary: OpsRamp Analytics SDK
+Provides: python-opsramp-analytics-utils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-opsramp-analytics-utils
+## OpsRamp Analytics Utilities
+
+This is the SDK for writing OpsRamp analytics apps. It is based on [dash](https://plotly.com/dash/), and it has a number of utility functions.
+
+It contains [analysis wrapper project](https://github.com/opsramp/analysis-wrapper).
+
+It is published on [Pypi](https://pypi.org/project/opsramp-analytics-utils/)
+
+#### How to publish on Pypi
+
+After make updates on SDK, modify the version in _setup.py_.
+
+```
+python setup.py sdist bdist_wheel
+python -m twine upload dist/*
+
+Note: if above command not works, then use below command
+python -m twine upload --skip-existing dist/*
+```
+
+- To upgrade the sdk for your app
+```
+pip install --no-cache-dir --upgrade opsramp-analytics-utils
+```
+
+
+
+
+%package help
+Summary: Development documents and examples for opsramp-analytics-utils
+Provides: python3-opsramp-analytics-utils-doc
+%description help
+## OpsRamp Analytics Utilities
+
+This is the SDK for writing OpsRamp analytics apps. It is based on [dash](https://plotly.com/dash/), and it has a number of utility functions.
+
+It contains [analysis wrapper project](https://github.com/opsramp/analysis-wrapper).
+
+It is published on [Pypi](https://pypi.org/project/opsramp-analytics-utils/)
+
+#### How to publish on Pypi
+
+After make updates on SDK, modify the version in _setup.py_.
+
+```
+python setup.py sdist bdist_wheel
+python -m twine upload dist/*
+
+Note: if above command not works, then use below command
+python -m twine upload --skip-existing dist/*
+```
+
+- To upgrade the sdk for your app
+```
+pip install --no-cache-dir --upgrade opsramp-analytics-utils
+```
+
+
+
+
+%prep
+%autosetup -n opsramp-analytics-utils-3.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-opsramp-analytics-utils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.3.1-1
+- Package Spec generated