summaryrefslogtreecommitdiff
path: root/python-packetvisualization.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-packetvisualization.spec')
-rw-r--r--python-packetvisualization.spec164
1 files changed, 164 insertions, 0 deletions
diff --git a/python-packetvisualization.spec b/python-packetvisualization.spec
new file mode 100644
index 0000000..2dac44d
--- /dev/null
+++ b/python-packetvisualization.spec
@@ -0,0 +1,164 @@
+%global _empty_manifest_terminate_build 0
+Name: python-packetvisualization
+Version: 1.0.3
+Release: 1
+Summary: packet visualization
+License: MIT License
+URL: https://gitlab.com/utep/packet-visualize
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/89/1f/08af66ccec003b2d046fdd547a4a6863528d0df741a03136c7cc5c4dbf8f/packetvisualization-1.0.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyshark
+Requires: python3-PyQt5
+Requires: python3-pandas
+Requires: python3-plotly
+Requires: python3-PyQtWebEngine
+Requires: python3-scapy
+Requires: python3-pymongo
+Requires: python3-decouple
+Requires: python3-certifi
+Requires: python3-liac-arff
+Requires: python3-sklearn
+
+%description
+## Requirements
+
+1. Have a local mongo db server installed and running. The program uses this to create a local db instance.
+2. Install wireshark and tshark
+3. Install suricata and modify `suricata.yaml` to export pcap file
+ - Default Locations:
+ - Windows: C:\Program Files\Suricata\suricata.yaml
+ - Linux: /etc/suricata/suricata/yaml
+```commandline
+- pcap-log:
+ - enabled: yes
+ - filename: log.pcap
+```
+## Run
+Once your changes are done and need to run the package as if you were a user of it.
+Follow these steps:
+1. Run *pip install packetvisualization*
+2. Run *python*
+3. Type
+ ```
+ from packetvisualization import run
+ run()
+ ```
+
+
+
+
+
+
+%package -n python3-packetvisualization
+Summary: packet visualization
+Provides: python-packetvisualization
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-packetvisualization
+## Requirements
+
+1. Have a local mongo db server installed and running. The program uses this to create a local db instance.
+2. Install wireshark and tshark
+3. Install suricata and modify `suricata.yaml` to export pcap file
+ - Default Locations:
+ - Windows: C:\Program Files\Suricata\suricata.yaml
+ - Linux: /etc/suricata/suricata/yaml
+```commandline
+- pcap-log:
+ - enabled: yes
+ - filename: log.pcap
+```
+## Run
+Once your changes are done and need to run the package as if you were a user of it.
+Follow these steps:
+1. Run *pip install packetvisualization*
+2. Run *python*
+3. Type
+ ```
+ from packetvisualization import run
+ run()
+ ```
+
+
+
+
+
+
+%package help
+Summary: Development documents and examples for packetvisualization
+Provides: python3-packetvisualization-doc
+%description help
+## Requirements
+
+1. Have a local mongo db server installed and running. The program uses this to create a local db instance.
+2. Install wireshark and tshark
+3. Install suricata and modify `suricata.yaml` to export pcap file
+ - Default Locations:
+ - Windows: C:\Program Files\Suricata\suricata.yaml
+ - Linux: /etc/suricata/suricata/yaml
+```commandline
+- pcap-log:
+ - enabled: yes
+ - filename: log.pcap
+```
+## Run
+Once your changes are done and need to run the package as if you were a user of it.
+Follow these steps:
+1. Run *pip install packetvisualization*
+2. Run *python*
+3. Type
+ ```
+ from packetvisualization import run
+ run()
+ ```
+
+
+
+
+
+
+%prep
+%autosetup -n packetvisualization-1.0.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-packetvisualization -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.3-1
+- Package Spec generated