summaryrefslogtreecommitdiff
path: root/python-papyrus.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-papyrus.spec')
-rw-r--r--python-papyrus.spec89
1 files changed, 89 insertions, 0 deletions
diff --git a/python-papyrus.spec b/python-papyrus.spec
new file mode 100644
index 0000000..feb4446
--- /dev/null
+++ b/python-papyrus.spec
@@ -0,0 +1,89 @@
+%global _empty_manifest_terminate_build 0
+Name: python-papyrus
+Version: 2.5
+Release: 1
+Summary: Geospatial Extensions for Pyramid
+License: BSD
+URL: https://github.com/camptocamp/papyrus
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ea/ca/ffb12201294317ac3a043853a403a8e69b52520c3883295aab402f4e012f/papyrus-2.5.tar.gz
+BuildArch: noarch
+
+Requires: python3-GeoAlchemy2
+Requires: python3-Shapely
+Requires: python3-geojson
+Requires: python3-pyramid
+Requires: python3-six
+
+%description
+Geospatial Extensions for the `Pyramid
+<http://docs.pylonsproject.org/en/latest/docs/pyramid.html>`_ web framework.
+The Papyrus doc is hosted on `Read the Docs <http://readthedocs.org/>`_.
+* Doc for current stable release: http://papyrus.readthedocs.org/en/stable/
+* Doc for current master branch: http://papyrus.readthedocs.org/en/latest/
+
+%package -n python3-papyrus
+Summary: Geospatial Extensions for Pyramid
+Provides: python-papyrus
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-papyrus
+Geospatial Extensions for the `Pyramid
+<http://docs.pylonsproject.org/en/latest/docs/pyramid.html>`_ web framework.
+The Papyrus doc is hosted on `Read the Docs <http://readthedocs.org/>`_.
+* Doc for current stable release: http://papyrus.readthedocs.org/en/stable/
+* Doc for current master branch: http://papyrus.readthedocs.org/en/latest/
+
+%package help
+Summary: Development documents and examples for papyrus
+Provides: python3-papyrus-doc
+%description help
+Geospatial Extensions for the `Pyramid
+<http://docs.pylonsproject.org/en/latest/docs/pyramid.html>`_ web framework.
+The Papyrus doc is hosted on `Read the Docs <http://readthedocs.org/>`_.
+* Doc for current stable release: http://papyrus.readthedocs.org/en/stable/
+* Doc for current master branch: http://papyrus.readthedocs.org/en/latest/
+
+%prep
+%autosetup -n papyrus-2.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-papyrus -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 2.5-1
+- Package Spec generated