summaryrefslogtreecommitdiff
path: root/python-paramz.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-paramz.spec')
-rw-r--r--python-paramz.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-paramz.spec b/python-paramz.spec
new file mode 100644
index 0000000..517576b
--- /dev/null
+++ b/python-paramz.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-paramz
+Version: 0.9.5
+Release: 1
+Summary: The Parameterization Framework
+License: BSD 3-clause
+URL: https://github.com/sods/paramz
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/d8/37/4abbeb78d30f20d3402887f46e6e9f3ef32034a9dea65d243654c82c8553/paramz-0.9.5.tar.gz
+BuildArch: noarch
+
+
+%description
+Please refer to the github homepage for detailed instructions on installation and usage.
+
+%package -n python3-paramz
+Summary: The Parameterization Framework
+Provides: python-paramz
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-paramz
+Please refer to the github homepage for detailed instructions on installation and usage.
+
+%package help
+Summary: Development documents and examples for paramz
+Provides: python3-paramz-doc
+%description help
+Please refer to the github homepage for detailed instructions on installation and usage.
+
+%prep
+%autosetup -n paramz-0.9.5
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-paramz -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.9.5-1
+- Package Spec generated