summaryrefslogtreecommitdiff
path: root/python-phylib.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 23:21:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 23:21:25 +0000
commit8ccd022298b038e98f5aa74464e2a2c33e7bcf94 (patch)
tree75119327cda77225bb080587170b47ac7223c2e9 /python-phylib.spec
parentd1d9699c3d4b72df6e1c05f7c16e3ca8628f1b8e (diff)
automatic import of python-phylib
Diffstat (limited to 'python-phylib.spec')
-rw-r--r--python-phylib.spec101
1 files changed, 101 insertions, 0 deletions
diff --git a/python-phylib.spec b/python-phylib.spec
new file mode 100644
index 0000000..a9e24ad
--- /dev/null
+++ b/python-phylib.spec
@@ -0,0 +1,101 @@
+%global _empty_manifest_terminate_build 0
+Name: python-phylib
+Version: 2.4.3
+Release: 1
+Summary: Ephys data analysis for thousands of channels
+License: BSD
+URL: https://github.com/cortex-lab/phylib
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bd/16/c911088471d6a39bc54fd3de8a9b652c0551ddb3d225d30bccdf9d002059/phylib-2.4.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-scipy
+Requires: python3-dask
+Requires: python3-requests
+Requires: python3-tqdm
+Requires: python3-toolz
+Requires: python3-joblib
+Requires: python3-mtscomp
+
+%description
+# phylib
+[![Build Status](https://img.shields.io/travis/cortex-lab/phylib.svg)](https://travis-ci.org/cortex-lab/phylib)
+[![codecov.io](https://img.shields.io/codecov/c/github/cortex-lab/phylib.svg)](http://codecov.io/github/cortex-lab/phylib?branch=master)
+
+Electrophysiological data analysis library used by [phy](https://github.com/kwikteam/phy/), a spike sorting visualization software, and [ibllib](https://github.com/int-brain-lab/ibllib/).
+
+
+
+
+%package -n python3-phylib
+Summary: Ephys data analysis for thousands of channels
+Provides: python-phylib
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-phylib
+# phylib
+[![Build Status](https://img.shields.io/travis/cortex-lab/phylib.svg)](https://travis-ci.org/cortex-lab/phylib)
+[![codecov.io](https://img.shields.io/codecov/c/github/cortex-lab/phylib.svg)](http://codecov.io/github/cortex-lab/phylib?branch=master)
+
+Electrophysiological data analysis library used by [phy](https://github.com/kwikteam/phy/), a spike sorting visualization software, and [ibllib](https://github.com/int-brain-lab/ibllib/).
+
+
+
+
+%package help
+Summary: Development documents and examples for phylib
+Provides: python3-phylib-doc
+%description help
+# phylib
+[![Build Status](https://img.shields.io/travis/cortex-lab/phylib.svg)](https://travis-ci.org/cortex-lab/phylib)
+[![codecov.io](https://img.shields.io/codecov/c/github/cortex-lab/phylib.svg)](http://codecov.io/github/cortex-lab/phylib?branch=master)
+
+Electrophysiological data analysis library used by [phy](https://github.com/kwikteam/phy/), a spike sorting visualization software, and [ibllib](https://github.com/int-brain-lab/ibllib/).
+
+
+
+
+%prep
+%autosetup -n phylib-2.4.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-phylib -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.4.3-1
+- Package Spec generated