summaryrefslogtreecommitdiff
path: root/python-poethepoet.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 04:17:20 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 04:17:20 +0000
commitf8bbb37e5fd84538384cddad1b34b81bcb49090d (patch)
tree265732cfd9e7f851422ebc4e390da36cf0229970 /python-poethepoet.spec
parent1b9d4d23c0482007ea6ea2ebba5f639b9382e99e (diff)
automatic import of python-poethepoet
Diffstat (limited to 'python-poethepoet.spec')
-rw-r--r--python-poethepoet.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-poethepoet.spec b/python-poethepoet.spec
new file mode 100644
index 0000000..eedac79
--- /dev/null
+++ b/python-poethepoet.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-poethepoet
+Version: 0.19.0
+Release: 1
+Summary: A task runner that works well with poetry.
+License: MIT
+URL: https://github.com/nat-n/poethepoet
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/22/84e02199b0e2223f7b63d2cd9ca00f9fee97bccc9e4c6673cb5d40bc44b1/poethepoet-0.19.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pastel
+Requires: python3-tomli
+Requires: python3-poetry
+
+%description
+|•| Straight forward declaration of project tasks in your pyproject.toml (kind of like npm scripts)
+|•| Task are run in poetry's virtualenv (or another env you specify)
+|•| Shell completion of task names (and global options too for zsh)
+|•| Can be used standalone or as a poetry plugin
+|•| Tasks can be commands (with or without a shell) or references to python functions (like tool.poetry.scripts)
+|•| Short and sweet commands with extra arguments passed to the task :bash:`poe [options] task [task_args]`, or you can define arguments explicitly.
+|•| Tasks can specify and reference environment variables as if they were evaluated by a shell
+|•| Tasks are self documenting, with optional help messages (just run poe without arguments)
+|•| Tasks can be defined as a sequence of other tasks
+|•| Works with .env files
+
+%package -n python3-poethepoet
+Summary: A task runner that works well with poetry.
+Provides: python-poethepoet
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-poethepoet
+|•| Straight forward declaration of project tasks in your pyproject.toml (kind of like npm scripts)
+|•| Task are run in poetry's virtualenv (or another env you specify)
+|•| Shell completion of task names (and global options too for zsh)
+|•| Can be used standalone or as a poetry plugin
+|•| Tasks can be commands (with or without a shell) or references to python functions (like tool.poetry.scripts)
+|•| Short and sweet commands with extra arguments passed to the task :bash:`poe [options] task [task_args]`, or you can define arguments explicitly.
+|•| Tasks can specify and reference environment variables as if they were evaluated by a shell
+|•| Tasks are self documenting, with optional help messages (just run poe without arguments)
+|•| Tasks can be defined as a sequence of other tasks
+|•| Works with .env files
+
+%package help
+Summary: Development documents and examples for poethepoet
+Provides: python3-poethepoet-doc
+%description help
+|•| Straight forward declaration of project tasks in your pyproject.toml (kind of like npm scripts)
+|•| Task are run in poetry's virtualenv (or another env you specify)
+|•| Shell completion of task names (and global options too for zsh)
+|•| Can be used standalone or as a poetry plugin
+|•| Tasks can be commands (with or without a shell) or references to python functions (like tool.poetry.scripts)
+|•| Short and sweet commands with extra arguments passed to the task :bash:`poe [options] task [task_args]`, or you can define arguments explicitly.
+|•| Tasks can specify and reference environment variables as if they were evaluated by a shell
+|•| Tasks are self documenting, with optional help messages (just run poe without arguments)
+|•| Tasks can be defined as a sequence of other tasks
+|•| Works with .env files
+
+%prep
+%autosetup -n poethepoet-0.19.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-poethepoet -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.19.0-1
+- Package Spec generated