summaryrefslogtreecommitdiff
path: root/python-powerline-status.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-powerline-status.spec')
-rw-r--r--python-powerline-status.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-powerline-status.spec b/python-powerline-status.spec
new file mode 100644
index 0000000..458c8ed
--- /dev/null
+++ b/python-powerline-status.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-powerline-status
+Version: 2.7
+Release: 1
+Summary: The ultimate statusline/prompt utility.
+License: MIT
+URL: https://github.com/powerline/powerline
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9c/30/8bd3c62642778af9ad813a526c6ff7dd2f98144d6580ad6fab94ca389265/powerline-status-2.7.tar.gz
+BuildArch: noarch
+
+
+%description
+**Powerline is a statusline plugin for vim, and provides statuslines and
+prompts for several other applications, including zsh, bash, fish, tmux,
+IPython, Awesome, i3 and Qtile.**
+* `Support forum`_ (powerline-support@googlegroups.com)
+* `Development discussion`_ (powerline-dev@googlegroups.com)
+
+%package -n python3-powerline-status
+Summary: The ultimate statusline/prompt utility.
+Provides: python-powerline-status
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-powerline-status
+**Powerline is a statusline plugin for vim, and provides statuslines and
+prompts for several other applications, including zsh, bash, fish, tmux,
+IPython, Awesome, i3 and Qtile.**
+* `Support forum`_ (powerline-support@googlegroups.com)
+* `Development discussion`_ (powerline-dev@googlegroups.com)
+
+%package help
+Summary: Development documents and examples for powerline-status
+Provides: python3-powerline-status-doc
+%description help
+**Powerline is a statusline plugin for vim, and provides statuslines and
+prompts for several other applications, including zsh, bash, fish, tmux,
+IPython, Awesome, i3 and Qtile.**
+* `Support forum`_ (powerline-support@googlegroups.com)
+* `Development discussion`_ (powerline-dev@googlegroups.com)
+
+%prep
+%autosetup -n powerline-status-2.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-powerline-status -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.7-1
+- Package Spec generated