summaryrefslogtreecommitdiff
path: root/python-ppdeep.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ppdeep.spec')
-rw-r--r--python-ppdeep.spec87
1 files changed, 87 insertions, 0 deletions
diff --git a/python-ppdeep.spec b/python-ppdeep.spec
new file mode 100644
index 0000000..18c8851
--- /dev/null
+++ b/python-ppdeep.spec
@@ -0,0 +1,87 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ppdeep
+Version: 20200505
+Release: 1
+Summary: Pure-Python library for computing fuzzy hashes (ssdeep)
+License: Apache Software License
+URL: https://github.com/elceef/ppdeep
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/64/ad/ca722788606970d227b1778c158d4a04ffd8190487fa80b3273e3fa587ac/ppdeep-20200505.tar.gz
+BuildArch: noarch
+
+
+%description
+This is a pure-Python library for computing context triggered piecewise hashes
+(CTPH), also called fuzzy hashes, or often ssdeep after the name of a popular
+tool. At a very high level, fuzzy hashing is a way to determine whether two
+inputs are similar, rather than identical. Fuzzy hashes are widely adopted in
+digital forensics and malware detection.
+This implementation is based on SpamSum by Dr. Andrew Tridgell.
+
+%package -n python3-ppdeep
+Summary: Pure-Python library for computing fuzzy hashes (ssdeep)
+Provides: python-ppdeep
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ppdeep
+This is a pure-Python library for computing context triggered piecewise hashes
+(CTPH), also called fuzzy hashes, or often ssdeep after the name of a popular
+tool. At a very high level, fuzzy hashing is a way to determine whether two
+inputs are similar, rather than identical. Fuzzy hashes are widely adopted in
+digital forensics and malware detection.
+This implementation is based on SpamSum by Dr. Andrew Tridgell.
+
+%package help
+Summary: Development documents and examples for ppdeep
+Provides: python3-ppdeep-doc
+%description help
+This is a pure-Python library for computing context triggered piecewise hashes
+(CTPH), also called fuzzy hashes, or often ssdeep after the name of a popular
+tool. At a very high level, fuzzy hashing is a way to determine whether two
+inputs are similar, rather than identical. Fuzzy hashes are widely adopted in
+digital forensics and malware detection.
+This implementation is based on SpamSum by Dr. Andrew Tridgell.
+
+%prep
+%autosetup -n ppdeep-20200505
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ppdeep -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 20200505-1
+- Package Spec generated