summaryrefslogtreecommitdiff
path: root/python-proto-google-cloud-pubsub-v1.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-proto-google-cloud-pubsub-v1.spec')
-rw-r--r--python-proto-google-cloud-pubsub-v1.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-proto-google-cloud-pubsub-v1.spec b/python-proto-google-cloud-pubsub-v1.spec
new file mode 100644
index 0000000..d072a36
--- /dev/null
+++ b/python-proto-google-cloud-pubsub-v1.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-proto-google-cloud-pubsub-v1
+Version: 0.15.4
+Release: 1
+Summary: GRPC library for the Google Cloud Pub/Sub API
+License: Apache-2.0
+URL: https://github.com/googleapis/googleapis
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c0/a2/2eeffa0069830f00016196dfdd69491cf562372b5353f2e8e378b3c2cb0a/proto-google-cloud-pubsub-v1-0.15.4.tar.gz
+BuildArch: noarch
+
+
+%description
+gRPC library for Google Cloud Pub/Sub API
+
+proto-google-cloud-pubsub-v1 is the IDL-derived library for the pubsub (v1) service in the googleapis_ repository.
+
+.. _`googleapis`: https://github.com/googleapis/googleapis/tree/master/google/pubsub/v1
+
+%package -n python3-proto-google-cloud-pubsub-v1
+Summary: GRPC library for the Google Cloud Pub/Sub API
+Provides: python-proto-google-cloud-pubsub-v1
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-proto-google-cloud-pubsub-v1
+gRPC library for Google Cloud Pub/Sub API
+
+proto-google-cloud-pubsub-v1 is the IDL-derived library for the pubsub (v1) service in the googleapis_ repository.
+
+.. _`googleapis`: https://github.com/googleapis/googleapis/tree/master/google/pubsub/v1
+
+%package help
+Summary: Development documents and examples for proto-google-cloud-pubsub-v1
+Provides: python3-proto-google-cloud-pubsub-v1-doc
+%description help
+gRPC library for Google Cloud Pub/Sub API
+
+proto-google-cloud-pubsub-v1 is the IDL-derived library for the pubsub (v1) service in the googleapis_ repository.
+
+.. _`googleapis`: https://github.com/googleapis/googleapis/tree/master/google/pubsub/v1
+
+%prep
+%autosetup -n proto-google-cloud-pubsub-v1-0.15.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-proto-google-cloud-pubsub-v1 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.15.4-1
+- Package Spec generated