summaryrefslogtreecommitdiff
path: root/python-ps2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-ps2.spec')
-rw-r--r--python-ps2.spec378
1 files changed, 378 insertions, 0 deletions
diff --git a/python-ps2.spec b/python-ps2.spec
new file mode 100644
index 0000000..9c9d148
--- /dev/null
+++ b/python-ps2.spec
@@ -0,0 +1,378 @@
+%global _empty_manifest_terminate_build 0
+Name: python-ps2
+Version: 0.1.4
+Release: 1
+Summary: Show process list.
+License: MIT
+URL: https://pypi.org/project/ps2/
+Source0: https://mirrors.aliyun.com/pypi/web/packages/72/03/5dc3d23042b0720282ecd47a65be9ab7efae6831ead58bd40538b29af061/ps2-0.1.4.tar.gz
+BuildArch: noarch
+
+
+%description
+# ps2
+
+ps tools that can be used in Linux/MacOS/Windows.
+
+## Install
+
+```shell
+pip install ps2
+```
+
+## Usage
+
+```shell
+ zencore:scripts zencore$ python3 ps2.py --help
+ Usage: ps2.py [OPTIONS] [OUTPUT]
+
+ The keywords can be used in output template:
+
+ cmdline
+ connections
+ cpu_percent
+ cpu_times
+ create_time
+ cwd
+ elapsed_time
+ environ
+ exe
+ gids
+ memory_full_info
+ memory_info
+ memory_info_ex
+ memory_maps
+ memory_percent
+ name
+ nice
+ num_ctx_switches
+ num_fds
+ num_threads
+ open_files
+ pid
+ ppid
+ status
+ threads
+ uids
+ username
+
+ The default output template is:
+
+ "{pid}\t{name}"
+
+ Options:
+ --help Show this message and exit.
+```
+
+## Example 1
+
+By default, ps2 show pid and name.
+
+```shell
+ zencore:scripts zencore$ ps2
+ 0 kernel_task
+ 89 loginwindow
+ 282 cfprefsd
+ 283 distnoted
+ 287 lsd
+ 306 UserEventAgent
+ 311 CommCenter
+ 312 trustd
+ 313 sharedfilelistd
+ 315 Terminal
+ ...
+```
+
+
+## Example 2
+
+You can customize the output template, there are many KEYWORDS provided for you to use.
+
+```shell
+ zencore:scripts zencore$ ps2 '{pid}\t{elapsed_time}\t{cmdline}'
+ 0 682055.9033548832
+ 89 682043.2770848274 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
+ 282 681934.4019351006 /usr/sbin/cfprefsd agent
+ 283 681934.2526762486 /usr/sbin/distnoted agent
+ 287 681933.4957187176 /usr/libexec/lsd
+ 306 681855.2815728188 /usr/libexec/UserEventAgent '(Aqua)'
+ 311 681855.1821689606 /System/Library/Frameworks/CoreTelephony.framework/Support/CommCenter -L
+ 312 681855.1382620335 /usr/libexec/trustd --agent
+ 313 681855.0924699306 /System/Library/CoreServices/sharedfilelistd
+ 315 681854.9572939873 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal -psn_0_69649
+```
+
+
+## Releases
+
+### 0.2.0 2019/12/06
+
+- Fix package structure, remove src folder and put ps.py at the root of project folder.
+- Change long description format from .rst to .md.
+
+### 0.1.3 2018/04/18
+
+- First stable release.
+
+%package -n python3-ps2
+Summary: Show process list.
+Provides: python-ps2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-ps2
+# ps2
+
+ps tools that can be used in Linux/MacOS/Windows.
+
+## Install
+
+```shell
+pip install ps2
+```
+
+## Usage
+
+```shell
+ zencore:scripts zencore$ python3 ps2.py --help
+ Usage: ps2.py [OPTIONS] [OUTPUT]
+
+ The keywords can be used in output template:
+
+ cmdline
+ connections
+ cpu_percent
+ cpu_times
+ create_time
+ cwd
+ elapsed_time
+ environ
+ exe
+ gids
+ memory_full_info
+ memory_info
+ memory_info_ex
+ memory_maps
+ memory_percent
+ name
+ nice
+ num_ctx_switches
+ num_fds
+ num_threads
+ open_files
+ pid
+ ppid
+ status
+ threads
+ uids
+ username
+
+ The default output template is:
+
+ "{pid}\t{name}"
+
+ Options:
+ --help Show this message and exit.
+```
+
+## Example 1
+
+By default, ps2 show pid and name.
+
+```shell
+ zencore:scripts zencore$ ps2
+ 0 kernel_task
+ 89 loginwindow
+ 282 cfprefsd
+ 283 distnoted
+ 287 lsd
+ 306 UserEventAgent
+ 311 CommCenter
+ 312 trustd
+ 313 sharedfilelistd
+ 315 Terminal
+ ...
+```
+
+
+## Example 2
+
+You can customize the output template, there are many KEYWORDS provided for you to use.
+
+```shell
+ zencore:scripts zencore$ ps2 '{pid}\t{elapsed_time}\t{cmdline}'
+ 0 682055.9033548832
+ 89 682043.2770848274 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
+ 282 681934.4019351006 /usr/sbin/cfprefsd agent
+ 283 681934.2526762486 /usr/sbin/distnoted agent
+ 287 681933.4957187176 /usr/libexec/lsd
+ 306 681855.2815728188 /usr/libexec/UserEventAgent '(Aqua)'
+ 311 681855.1821689606 /System/Library/Frameworks/CoreTelephony.framework/Support/CommCenter -L
+ 312 681855.1382620335 /usr/libexec/trustd --agent
+ 313 681855.0924699306 /System/Library/CoreServices/sharedfilelistd
+ 315 681854.9572939873 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal -psn_0_69649
+```
+
+
+## Releases
+
+### 0.2.0 2019/12/06
+
+- Fix package structure, remove src folder and put ps.py at the root of project folder.
+- Change long description format from .rst to .md.
+
+### 0.1.3 2018/04/18
+
+- First stable release.
+
+%package help
+Summary: Development documents and examples for ps2
+Provides: python3-ps2-doc
+%description help
+# ps2
+
+ps tools that can be used in Linux/MacOS/Windows.
+
+## Install
+
+```shell
+pip install ps2
+```
+
+## Usage
+
+```shell
+ zencore:scripts zencore$ python3 ps2.py --help
+ Usage: ps2.py [OPTIONS] [OUTPUT]
+
+ The keywords can be used in output template:
+
+ cmdline
+ connections
+ cpu_percent
+ cpu_times
+ create_time
+ cwd
+ elapsed_time
+ environ
+ exe
+ gids
+ memory_full_info
+ memory_info
+ memory_info_ex
+ memory_maps
+ memory_percent
+ name
+ nice
+ num_ctx_switches
+ num_fds
+ num_threads
+ open_files
+ pid
+ ppid
+ status
+ threads
+ uids
+ username
+
+ The default output template is:
+
+ "{pid}\t{name}"
+
+ Options:
+ --help Show this message and exit.
+```
+
+## Example 1
+
+By default, ps2 show pid and name.
+
+```shell
+ zencore:scripts zencore$ ps2
+ 0 kernel_task
+ 89 loginwindow
+ 282 cfprefsd
+ 283 distnoted
+ 287 lsd
+ 306 UserEventAgent
+ 311 CommCenter
+ 312 trustd
+ 313 sharedfilelistd
+ 315 Terminal
+ ...
+```
+
+
+## Example 2
+
+You can customize the output template, there are many KEYWORDS provided for you to use.
+
+```shell
+ zencore:scripts zencore$ ps2 '{pid}\t{elapsed_time}\t{cmdline}'
+ 0 682055.9033548832
+ 89 682043.2770848274 /System/Library/CoreServices/loginwindow.app/Contents/MacOS/loginwindow console
+ 282 681934.4019351006 /usr/sbin/cfprefsd agent
+ 283 681934.2526762486 /usr/sbin/distnoted agent
+ 287 681933.4957187176 /usr/libexec/lsd
+ 306 681855.2815728188 /usr/libexec/UserEventAgent '(Aqua)'
+ 311 681855.1821689606 /System/Library/Frameworks/CoreTelephony.framework/Support/CommCenter -L
+ 312 681855.1382620335 /usr/libexec/trustd --agent
+ 313 681855.0924699306 /System/Library/CoreServices/sharedfilelistd
+ 315 681854.9572939873 /Applications/Utilities/Terminal.app/Contents/MacOS/Terminal -psn_0_69649
+```
+
+
+## Releases
+
+### 0.2.0 2019/12/06
+
+- Fix package structure, remove src folder and put ps.py at the root of project folder.
+- Change long description format from .rst to .md.
+
+### 0.1.3 2018/04/18
+
+- First stable release.
+
+%prep
+%autosetup -n ps2-0.1.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-ps2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.4-1
+- Package Spec generated