summaryrefslogtreecommitdiff
path: root/python-pulumi-hcloud.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-29 12:30:25 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-29 12:30:25 +0000
commitf81f765b52d3b737730d009aec1c21bfc8ef105e (patch)
treef7ce2fcd75da4f10c89c5efabf1f0fd3994e5aa1 /python-pulumi-hcloud.spec
parent0e7e006149a1b5427a7a145c7401b4c2979cfb0e (diff)
automatic import of python-pulumi-hcloud
Diffstat (limited to 'python-pulumi-hcloud.spec')
-rw-r--r--python-pulumi-hcloud.spec225
1 files changed, 225 insertions, 0 deletions
diff --git a/python-pulumi-hcloud.spec b/python-pulumi-hcloud.spec
new file mode 100644
index 0000000..d2b5ff7
--- /dev/null
+++ b/python-pulumi-hcloud.spec
@@ -0,0 +1,225 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pulumi-hcloud
+Version: 1.12.0
+Release: 1
+Summary: A Pulumi package for creating and managing hcloud cloud resources.
+License: Apache-2.0
+URL: https://pulumi.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/12/66/7f238488ea974f9e870dc383bd97be0c88fc180b0fd5b7b0364ba21fc8c6/pulumi_hcloud-1.12.0.tar.gz
+BuildArch: noarch
+
+
+%description
+# HCloud provider
+
+The HCloud resource provider for Pulumi lets you use Hetzner Cloud resources in your infrastructure
+programs. To use this package, please [install the Pulumi CLI first](https://pulumi.io/).
+
+## Installing
+
+This package is available in many languages in the standard packaging formats.
+
+### Node.js (Java/TypeScript)
+
+To use from JavaScript or TypeScript in Node.js, install using either `npm`:
+
+ $ npm install @pulumi/hcloud
+
+or `yarn`:
+
+ $ yarn add @pulumi/hcloud
+
+### Python
+
+To use from Python, install using `pip`:
+
+ $ pip install pulumi-hcloud
+
+### Go
+
+To use from Go, use `go get` to grab the latest version of the library
+
+ $ go get github.com/pulumi/pulumi-hcloud/sdk
+
+### .NET
+
+To use from .NET, install using `dotnet add package`:
+
+ $ dotnet add package Pulumi.HCloud
+
+## Configuration
+
+The following configuration points are available:
+
+- `hcloud:token` - (Optional) This is the Hetzner Cloud API Token, can also be specified with the `HCLOUD_TOKEN` environment variable.
+- `hcloud:endpoint` - (Optional) Hetzner Cloud API endpoint, can be used to override the default API Endpoint `https://api.hetzner.cloud/v1`.
+- `hcloud:pollInterval` - (Optional) Configures the interval in which actions are polled by the client. Default `500ms`. Increase this interval if you run into rate limiting errors.
+
+
+## Reference
+
+For further information, please visit [the HCloud provider docs](https://www.pulumi.com/docs/intro/cloud-providers/hcloud) or for detailed reference documentation, please visit [the API docs](https://www.pulumi.com/docs/reference/pkg/hcloud).
+
+
+
+
+%package -n python3-pulumi-hcloud
+Summary: A Pulumi package for creating and managing hcloud cloud resources.
+Provides: python-pulumi-hcloud
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pulumi-hcloud
+# HCloud provider
+
+The HCloud resource provider for Pulumi lets you use Hetzner Cloud resources in your infrastructure
+programs. To use this package, please [install the Pulumi CLI first](https://pulumi.io/).
+
+## Installing
+
+This package is available in many languages in the standard packaging formats.
+
+### Node.js (Java/TypeScript)
+
+To use from JavaScript or TypeScript in Node.js, install using either `npm`:
+
+ $ npm install @pulumi/hcloud
+
+or `yarn`:
+
+ $ yarn add @pulumi/hcloud
+
+### Python
+
+To use from Python, install using `pip`:
+
+ $ pip install pulumi-hcloud
+
+### Go
+
+To use from Go, use `go get` to grab the latest version of the library
+
+ $ go get github.com/pulumi/pulumi-hcloud/sdk
+
+### .NET
+
+To use from .NET, install using `dotnet add package`:
+
+ $ dotnet add package Pulumi.HCloud
+
+## Configuration
+
+The following configuration points are available:
+
+- `hcloud:token` - (Optional) This is the Hetzner Cloud API Token, can also be specified with the `HCLOUD_TOKEN` environment variable.
+- `hcloud:endpoint` - (Optional) Hetzner Cloud API endpoint, can be used to override the default API Endpoint `https://api.hetzner.cloud/v1`.
+- `hcloud:pollInterval` - (Optional) Configures the interval in which actions are polled by the client. Default `500ms`. Increase this interval if you run into rate limiting errors.
+
+
+## Reference
+
+For further information, please visit [the HCloud provider docs](https://www.pulumi.com/docs/intro/cloud-providers/hcloud) or for detailed reference documentation, please visit [the API docs](https://www.pulumi.com/docs/reference/pkg/hcloud).
+
+
+
+
+%package help
+Summary: Development documents and examples for pulumi-hcloud
+Provides: python3-pulumi-hcloud-doc
+%description help
+# HCloud provider
+
+The HCloud resource provider for Pulumi lets you use Hetzner Cloud resources in your infrastructure
+programs. To use this package, please [install the Pulumi CLI first](https://pulumi.io/).
+
+## Installing
+
+This package is available in many languages in the standard packaging formats.
+
+### Node.js (Java/TypeScript)
+
+To use from JavaScript or TypeScript in Node.js, install using either `npm`:
+
+ $ npm install @pulumi/hcloud
+
+or `yarn`:
+
+ $ yarn add @pulumi/hcloud
+
+### Python
+
+To use from Python, install using `pip`:
+
+ $ pip install pulumi-hcloud
+
+### Go
+
+To use from Go, use `go get` to grab the latest version of the library
+
+ $ go get github.com/pulumi/pulumi-hcloud/sdk
+
+### .NET
+
+To use from .NET, install using `dotnet add package`:
+
+ $ dotnet add package Pulumi.HCloud
+
+## Configuration
+
+The following configuration points are available:
+
+- `hcloud:token` - (Optional) This is the Hetzner Cloud API Token, can also be specified with the `HCLOUD_TOKEN` environment variable.
+- `hcloud:endpoint` - (Optional) Hetzner Cloud API endpoint, can be used to override the default API Endpoint `https://api.hetzner.cloud/v1`.
+- `hcloud:pollInterval` - (Optional) Configures the interval in which actions are polled by the client. Default `500ms`. Increase this interval if you run into rate limiting errors.
+
+
+## Reference
+
+For further information, please visit [the HCloud provider docs](https://www.pulumi.com/docs/intro/cloud-providers/hcloud) or for detailed reference documentation, please visit [the API docs](https://www.pulumi.com/docs/reference/pkg/hcloud).
+
+
+
+
+%prep
+%autosetup -n pulumi-hcloud-1.12.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pulumi-hcloud -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 29 2023 Python_Bot <Python_Bot@openeuler.org> - 1.12.0-1
+- Package Spec generated