summaryrefslogtreecommitdiff
path: root/python-py-trello.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 03:20:33 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 03:20:33 +0000
commit35f28b1b6dece615e089778ca436a57b6de9d1a4 (patch)
treeeaf374f516c63f82f394b5073e24a6f2685ca12a /python-py-trello.spec
parent231bbc2c159da01d5047630a7b342467bac4e916 (diff)
automatic import of python-py-trello
Diffstat (limited to 'python-py-trello.spec')
-rw-r--r--python-py-trello.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-py-trello.spec b/python-py-trello.spec
new file mode 100644
index 0000000..09b42f4
--- /dev/null
+++ b/python-py-trello.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-py-trello
+Version: 0.19.0
+Release: 1
+Summary: Python wrapper around the Trello API
+License: BSD License
+URL: https://trello.com/board/py-trello/4f145d87b2f9f15d6d027b53
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/70/5b/c754443326efce32f65563d8453fbf44b05f0f72f24d330334fe6c27437f/py-trello-0.19.0.tar.gz
+BuildArch: noarch
+
+
+%description
+ pip install py-trello
+
+%package -n python3-py-trello
+Summary: Python wrapper around the Trello API
+Provides: python-py-trello
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-py-trello
+ pip install py-trello
+
+%package help
+Summary: Development documents and examples for py-trello
+Provides: python3-py-trello-doc
+%description help
+ pip install py-trello
+
+%prep
+%autosetup -n py-trello-0.19.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-py-trello -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.19.0-1
+- Package Spec generated