summaryrefslogtreecommitdiff
path: root/python-py4j.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-03-09 15:21:37 +0000
committerCoprDistGit <infra@openeuler.org>2023-03-09 15:21:37 +0000
commit3699c187f29e946d058e5a08b68e2af572be00d6 (patch)
treeef3e5830de5f888d7c1f4b76716a0b92ac87a0c1 /python-py4j.spec
parent4caf545a5d3420d578fd6b3057d2dab16017189b (diff)
automatic import of python-py4j
Diffstat (limited to 'python-py4j.spec')
-rw-r--r--python-py4j.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-py4j.spec b/python-py4j.spec
new file mode 100644
index 0000000..65f11e2
--- /dev/null
+++ b/python-py4j.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-py4j
+Version: 0.10.9.7
+Release: 1
+Summary: Enables Python programs to dynamically access arbitrary Java objects
+License: BSD License
+URL: https://www.py4j.org/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/1e/f2/b34255180c72c36ff7097f7c2cdca02abcbd89f5eebf7c7c41262a9a0637/py4j-0.10.9.7.tar.gz
+BuildArch: noarch
+
+
+%description
+Py4J enables Python programs running in a Python interpreter to dynamically access Java objects in a Java Virtual Machine. Methods are called as if the Java objects resided in the Python interpreter and Java collections can be accessed through standard Python collection methods. Py4J also enables Java programs to call back Python objects.
+
+
+
+%package -n python3-py4j
+Summary: Enables Python programs to dynamically access arbitrary Java objects
+Provides: python-py4j
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-py4j
+Py4J enables Python programs running in a Python interpreter to dynamically access Java objects in a Java Virtual Machine. Methods are called as if the Java objects resided in the Python interpreter and Java collections can be accessed through standard Python collection methods. Py4J also enables Java programs to call back Python objects.
+
+
+
+%package help
+Summary: Development documents and examples for py4j
+Provides: python3-py4j-doc
+%description help
+Py4J enables Python programs running in a Python interpreter to dynamically access Java objects in a Java Virtual Machine. Methods are called as if the Java objects resided in the Python interpreter and Java collections can be accessed through standard Python collection methods. Py4J also enables Java programs to call back Python objects.
+
+
+
+%prep
+%autosetup -n py4j-0.10.9.7
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-py4j -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.10.9.7-1
+- Package Spec generated