summaryrefslogtreecommitdiff
path: root/python-pyatlasclient.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 19:39:20 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 19:39:20 +0000
commit6703dcfa8db7411b3f6762c61f1b7d5d92aa4054 (patch)
tree4d7a12e3814b4b4fbf06c6e8ecee4ab2c68ee41e /python-pyatlasclient.spec
parent540fe85ea843249483a06e59f19e6a31cb0f4569 (diff)
automatic import of python-pyatlasclient
Diffstat (limited to 'python-pyatlasclient.spec')
-rw-r--r--python-pyatlasclient.spec181
1 files changed, 181 insertions, 0 deletions
diff --git a/python-pyatlasclient.spec b/python-pyatlasclient.spec
new file mode 100644
index 0000000..22cdd7d
--- /dev/null
+++ b/python-pyatlasclient.spec
@@ -0,0 +1,181 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyatlasclient
+Version: 1.2.0
+Release: 1
+Summary: Apache Atlas Python Client
+License: Apache Software License 2.0
+URL: https://github.com/verdan/pyatlasclient
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/be/4b/ce43e23be94d751ea82462e20a8312ac07fb8bcc77e9df3a8627a96b0037/pyatlasclient-1.2.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-six
+Requires: python3-Click
+Requires: python3-requests
+Requires: python3-pydantic
+
+%description
+[![image](https://img.shields.io/pypi/v/pyatlasclient.svg)](https://pypi.python.org/pypi/pyatlasclient) [![image](https://img.shields.io/travis/verdan/pyatlasclient.svg)](https://travis-ci.org/verdan/pyatlasclient) [![image](https://coveralls.io/repos/github/verdan/pyatlasclient/badge.svg?branch=master)](https://coveralls.io/github/verdan/pyatlasclient?branch=master) [![Documentation Status](https://readthedocs.org/projects/pyatlasclient/badge/?version=latest)](https://pyatlasclient.readthedocs.io/en/latest/?badge=latest) [![Updates](https://pyup.io/repos/github/verdan/pyatlasclient/shield.svg)](https://pyup.io/repos/github/verdan/pyatlasclient/)
+Apache Atlas client in Python. Only compatible with Apache Atlas REST
+API **v2**.
+*Based on the awesome work done by Poullet in atlasclient*
+- Free software: Apache Software License 2.0
+- Documentation: <https://pyatlasclient.readthedocs.io>
+### Get started
+```python
+ from atlasclient.client import Atlas
+ client = Atlas('<atlas.host>', port=21000, username='admin', password='admin')
+ client.entity_guid("<guid>").status
+ params = {'typeName': 'DataSet', 'attrName': 'name', 'attrValue': 'data', 'offset': '1', 'limit':'10'}
+ search_results = client.search_attribute(**params)
+ for s in search_results:
+ for e in s.entities:
+ print(e.name)
+ print(e.guid)
+```
+### Features
+- Lazy loading: requests are only performed when data are required and
+ not yet available
+- Leverages Python\'s Data Classes for Glossary.
+- Resource object relationships: REST API from sub-resources are done
+ transparently for the user, for instance the user does not have to
+ know that it needs to trigger a different REST request for getting
+ the classifications of a specific entity.
+### TODO features
+- allow multiprocessing
+- Implement Caching
+- Apply Data Classes to all entity types. For now only Glossary
+ endpoints are using it.
+### Credits
+This package was created with
+[Cookiecutter](https://github.com/audreyr/cookiecutter) and the
+[audreyr/cookiecutter-pypackage](https://github.com/audreyr/cookiecutter-pypackage)
+project template.
+
+%package -n python3-pyatlasclient
+Summary: Apache Atlas Python Client
+Provides: python-pyatlasclient
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyatlasclient
+[![image](https://img.shields.io/pypi/v/pyatlasclient.svg)](https://pypi.python.org/pypi/pyatlasclient) [![image](https://img.shields.io/travis/verdan/pyatlasclient.svg)](https://travis-ci.org/verdan/pyatlasclient) [![image](https://coveralls.io/repos/github/verdan/pyatlasclient/badge.svg?branch=master)](https://coveralls.io/github/verdan/pyatlasclient?branch=master) [![Documentation Status](https://readthedocs.org/projects/pyatlasclient/badge/?version=latest)](https://pyatlasclient.readthedocs.io/en/latest/?badge=latest) [![Updates](https://pyup.io/repos/github/verdan/pyatlasclient/shield.svg)](https://pyup.io/repos/github/verdan/pyatlasclient/)
+Apache Atlas client in Python. Only compatible with Apache Atlas REST
+API **v2**.
+*Based on the awesome work done by Poullet in atlasclient*
+- Free software: Apache Software License 2.0
+- Documentation: <https://pyatlasclient.readthedocs.io>
+### Get started
+```python
+ from atlasclient.client import Atlas
+ client = Atlas('<atlas.host>', port=21000, username='admin', password='admin')
+ client.entity_guid("<guid>").status
+ params = {'typeName': 'DataSet', 'attrName': 'name', 'attrValue': 'data', 'offset': '1', 'limit':'10'}
+ search_results = client.search_attribute(**params)
+ for s in search_results:
+ for e in s.entities:
+ print(e.name)
+ print(e.guid)
+```
+### Features
+- Lazy loading: requests are only performed when data are required and
+ not yet available
+- Leverages Python\'s Data Classes for Glossary.
+- Resource object relationships: REST API from sub-resources are done
+ transparently for the user, for instance the user does not have to
+ know that it needs to trigger a different REST request for getting
+ the classifications of a specific entity.
+### TODO features
+- allow multiprocessing
+- Implement Caching
+- Apply Data Classes to all entity types. For now only Glossary
+ endpoints are using it.
+### Credits
+This package was created with
+[Cookiecutter](https://github.com/audreyr/cookiecutter) and the
+[audreyr/cookiecutter-pypackage](https://github.com/audreyr/cookiecutter-pypackage)
+project template.
+
+%package help
+Summary: Development documents and examples for pyatlasclient
+Provides: python3-pyatlasclient-doc
+%description help
+[![image](https://img.shields.io/pypi/v/pyatlasclient.svg)](https://pypi.python.org/pypi/pyatlasclient) [![image](https://img.shields.io/travis/verdan/pyatlasclient.svg)](https://travis-ci.org/verdan/pyatlasclient) [![image](https://coveralls.io/repos/github/verdan/pyatlasclient/badge.svg?branch=master)](https://coveralls.io/github/verdan/pyatlasclient?branch=master) [![Documentation Status](https://readthedocs.org/projects/pyatlasclient/badge/?version=latest)](https://pyatlasclient.readthedocs.io/en/latest/?badge=latest) [![Updates](https://pyup.io/repos/github/verdan/pyatlasclient/shield.svg)](https://pyup.io/repos/github/verdan/pyatlasclient/)
+Apache Atlas client in Python. Only compatible with Apache Atlas REST
+API **v2**.
+*Based on the awesome work done by Poullet in atlasclient*
+- Free software: Apache Software License 2.0
+- Documentation: <https://pyatlasclient.readthedocs.io>
+### Get started
+```python
+ from atlasclient.client import Atlas
+ client = Atlas('<atlas.host>', port=21000, username='admin', password='admin')
+ client.entity_guid("<guid>").status
+ params = {'typeName': 'DataSet', 'attrName': 'name', 'attrValue': 'data', 'offset': '1', 'limit':'10'}
+ search_results = client.search_attribute(**params)
+ for s in search_results:
+ for e in s.entities:
+ print(e.name)
+ print(e.guid)
+```
+### Features
+- Lazy loading: requests are only performed when data are required and
+ not yet available
+- Leverages Python\'s Data Classes for Glossary.
+- Resource object relationships: REST API from sub-resources are done
+ transparently for the user, for instance the user does not have to
+ know that it needs to trigger a different REST request for getting
+ the classifications of a specific entity.
+### TODO features
+- allow multiprocessing
+- Implement Caching
+- Apply Data Classes to all entity types. For now only Glossary
+ endpoints are using it.
+### Credits
+This package was created with
+[Cookiecutter](https://github.com/audreyr/cookiecutter) and the
+[audreyr/cookiecutter-pypackage](https://github.com/audreyr/cookiecutter-pypackage)
+project template.
+
+%prep
+%autosetup -n pyatlasclient-1.2.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyatlasclient -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.0-1
+- Package Spec generated