summaryrefslogtreecommitdiff
path: root/python-pyaxmlparser.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyaxmlparser.spec')
-rw-r--r--python-pyaxmlparser.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-pyaxmlparser.spec b/python-pyaxmlparser.spec
new file mode 100644
index 0000000..c15b3bd
--- /dev/null
+++ b/python-pyaxmlparser.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyaxmlparser
+Version: 0.3.28
+Release: 1
+Summary: Python3 Parser for Android XML file and get Application Name without using Androguard
+License: Apache License 2.0
+URL: https://github.com/appknox/pyaxmlparser
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/58/7f/327c19329f535c332451b5f1f906bff5f952fe3070d00376b75e67052f35/pyaxmlparser-0.3.28.tar.gz
+BuildArch: noarch
+
+Requires: python3-lxml
+Requires: python3-click
+Requires: python3-asn1crypto
+
+%description
+A simple parser to parse Android XML file.
+
+%package -n python3-pyaxmlparser
+Summary: Python3 Parser for Android XML file and get Application Name without using Androguard
+Provides: python-pyaxmlparser
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyaxmlparser
+A simple parser to parse Android XML file.
+
+%package help
+Summary: Development documents and examples for pyaxmlparser
+Provides: python3-pyaxmlparser-doc
+%description help
+A simple parser to parse Android XML file.
+
+%prep
+%autosetup -n pyaxmlparser-0.3.28
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyaxmlparser -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.28-1
+- Package Spec generated