summaryrefslogtreecommitdiff
path: root/python-pyccuracy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyccuracy.spec')
-rw-r--r--python-pyccuracy.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pyccuracy.spec b/python-pyccuracy.spec
new file mode 100644
index 0000000..9de00e7
--- /dev/null
+++ b/python-pyccuracy.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-Pyccuracy
+Version: 1.2.47
+Release: 1
+Summary: Pyccuracy is a BDD style Acceptance Testing framework
+License: OSI
+URL: http://www.pyccuracy.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c1/39/e948e33899d00216d48fd07879561bf26c233833e9b162e3e6f06b3c0d50/Pyccuracy-1.2.47.tar.gz
+BuildArch: noarch
+
+
+%description
+Pyccuracy is a Behavior-Driven Acceptance Testing framework (more on http://www.pyccuracy.org).
+
+%package -n python3-Pyccuracy
+Summary: Pyccuracy is a BDD style Acceptance Testing framework
+Provides: python-Pyccuracy
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-Pyccuracy
+Pyccuracy is a Behavior-Driven Acceptance Testing framework (more on http://www.pyccuracy.org).
+
+%package help
+Summary: Development documents and examples for Pyccuracy
+Provides: python3-Pyccuracy-doc
+%description help
+Pyccuracy is a Behavior-Driven Acceptance Testing framework (more on http://www.pyccuracy.org).
+
+%prep
+%autosetup -n Pyccuracy-1.2.47
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-Pyccuracy -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon May 15 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.47-1
+- Package Spec generated