summaryrefslogtreecommitdiff
path: root/python-pycec.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pycec.spec')
-rw-r--r--python-pycec.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-pycec.spec b/python-pycec.spec
new file mode 100644
index 0000000..b8e23a3
--- /dev/null
+++ b/python-pycec.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyCEC
+Version: 0.5.2
+Release: 1
+Summary: Provide HDMI CEC devices as objects, especially for use with Home Assistant
+License: MIT
+URL: https://github.com/konikvranik/pycec/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f4/bb/d407b6285f6dd7c30b33568f4af50b3b7c57bc4e9382e7878a20ddefe1be/pyCEC-0.5.2.tar.gz
+BuildArch: noarch
+
+
+%description
+Purpose of this project is to provide object API to libcec for
+home-assistant hdmi\_cec module as `primary
+goal <https://github.com/konikvranik/pyCEC/projects/1>`__ and to make
+TCP <=> HDMI bridge to control HDMI devices over TCP network as a
+`secondary goal <https://github.com/konikvranik/pyCEC/projects/2>`__.
+
+%package -n python3-pyCEC
+Summary: Provide HDMI CEC devices as objects, especially for use with Home Assistant
+Provides: python-pyCEC
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyCEC
+Purpose of this project is to provide object API to libcec for
+home-assistant hdmi\_cec module as `primary
+goal <https://github.com/konikvranik/pyCEC/projects/1>`__ and to make
+TCP <=> HDMI bridge to control HDMI devices over TCP network as a
+`secondary goal <https://github.com/konikvranik/pyCEC/projects/2>`__.
+
+%package help
+Summary: Development documents and examples for pyCEC
+Provides: python3-pyCEC-doc
+%description help
+Purpose of this project is to provide object API to libcec for
+home-assistant hdmi\_cec module as `primary
+goal <https://github.com/konikvranik/pyCEC/projects/1>`__ and to make
+TCP <=> HDMI bridge to control HDMI devices over TCP network as a
+`secondary goal <https://github.com/konikvranik/pyCEC/projects/2>`__.
+
+%prep
+%autosetup -n pyCEC-0.5.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyCEC -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.5.2-1
+- Package Spec generated