summaryrefslogtreecommitdiff
path: root/python-pycrate.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pycrate.spec')
-rw-r--r--python-pycrate.spec102
1 files changed, 102 insertions, 0 deletions
diff --git a/python-pycrate.spec b/python-pycrate.spec
new file mode 100644
index 0000000..8de2262
--- /dev/null
+++ b/python-pycrate.spec
@@ -0,0 +1,102 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pycrate
+Version: 0.6.0
+Release: 1
+Summary: A software suite to handle various data and protocol formats
+License: LGPL v2.1+
+URL: https://github.com/P1sec/pycrate/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/7f/5f354100270a5d41350e9806dc9950a33e00a30eb3a7ab5fc9db86326856/pycrate-0.6.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-CryptoMobile
+Requires: python3-CryptoMobile
+Requires: python3-crcmod
+Requires: python3-pysctp
+Requires: python3-CryptoMobile
+Requires: python3-lxml
+
+%description
+Pycrate is a french word for qualifying bad wine (when it's close to vinegar !).
+The present software library has nothing to do with wine (except it is developed in France),
+it is simply a Python library for manipulating various digital formats in an easy way,
+with a funny name. Most of the format supported are related in one way or another
+to cellular network's signalling.
+It is the glorious successor of [libmich](https://github.com/mitshell/libmich),
+which was started back in 2009, served well and retired in 2017.
+It provides basically a runtime for encoding and decoding data structures, including
+CSN.1 and ASN.1. Additionally, it features a 3G and LTE mobile core network.
+
+%package -n python3-pycrate
+Summary: A software suite to handle various data and protocol formats
+Provides: python-pycrate
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pycrate
+Pycrate is a french word for qualifying bad wine (when it's close to vinegar !).
+The present software library has nothing to do with wine (except it is developed in France),
+it is simply a Python library for manipulating various digital formats in an easy way,
+with a funny name. Most of the format supported are related in one way or another
+to cellular network's signalling.
+It is the glorious successor of [libmich](https://github.com/mitshell/libmich),
+which was started back in 2009, served well and retired in 2017.
+It provides basically a runtime for encoding and decoding data structures, including
+CSN.1 and ASN.1. Additionally, it features a 3G and LTE mobile core network.
+
+%package help
+Summary: Development documents and examples for pycrate
+Provides: python3-pycrate-doc
+%description help
+Pycrate is a french word for qualifying bad wine (when it's close to vinegar !).
+The present software library has nothing to do with wine (except it is developed in France),
+it is simply a Python library for manipulating various digital formats in an easy way,
+with a funny name. Most of the format supported are related in one way or another
+to cellular network's signalling.
+It is the glorious successor of [libmich](https://github.com/mitshell/libmich),
+which was started back in 2009, served well and retired in 2017.
+It provides basically a runtime for encoding and decoding data structures, including
+CSN.1 and ASN.1. Additionally, it features a 3G and LTE mobile core network.
+
+%prep
+%autosetup -n pycrate-0.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pycrate -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
+- Package Spec generated