summaryrefslogtreecommitdiff
path: root/python-pydenticon.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pydenticon.spec')
-rw-r--r--python-pydenticon.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-pydenticon.spec b/python-pydenticon.spec
new file mode 100644
index 0000000..51a2cab
--- /dev/null
+++ b/python-pydenticon.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pydenticon
+Version: 0.3.1
+Release: 1
+Summary: Library for generating identicons. Port of Sigil (https://github.com/cupcake/sigil) with enhancements.
+License: BSD
+URL: https://github.com/azaghal/pydenticon
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/76/fa/3085252e2cfd8353624142fb18ca007a2ce4fe199a1440ea3c85ec5b8620/pydenticon-0.3.1.tar.gz
+BuildArch: noarch
+
+
+%description
+Pydenticon is a small utility library that can be used for deterministically
+generating identicons based on the hash of provided data.
+The implementation is a port of the Sigil identicon implementation from:
+* https://github.com/cupcake/sigil/
+Pydenticon provides a couple of extensions of its own when compared to the
+original Sigil implementation, like:
+* Ability to supply custom digest algorithms (allowing for larger identicons if
+ digest provides enough entropy).
+* Ability to specify a rectangle for identicon size..
+
+%package -n python3-pydenticon
+Summary: Library for generating identicons. Port of Sigil (https://github.com/cupcake/sigil) with enhancements.
+Provides: python-pydenticon
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pydenticon
+Pydenticon is a small utility library that can be used for deterministically
+generating identicons based on the hash of provided data.
+The implementation is a port of the Sigil identicon implementation from:
+* https://github.com/cupcake/sigil/
+Pydenticon provides a couple of extensions of its own when compared to the
+original Sigil implementation, like:
+* Ability to supply custom digest algorithms (allowing for larger identicons if
+ digest provides enough entropy).
+* Ability to specify a rectangle for identicon size..
+
+%package help
+Summary: Development documents and examples for pydenticon
+Provides: python3-pydenticon-doc
+%description help
+Pydenticon is a small utility library that can be used for deterministically
+generating identicons based on the hash of provided data.
+The implementation is a port of the Sigil identicon implementation from:
+* https://github.com/cupcake/sigil/
+Pydenticon provides a couple of extensions of its own when compared to the
+original Sigil implementation, like:
+* Ability to supply custom digest algorithms (allowing for larger identicons if
+ digest provides enough entropy).
+* Ability to specify a rectangle for identicon size..
+
+%prep
+%autosetup -n pydenticon-0.3.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pydenticon -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.1-1
+- Package Spec generated