summaryrefslogtreecommitdiff
path: root/python-pyduofern.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyduofern.spec')
-rw-r--r--python-pyduofern.spec176
1 files changed, 176 insertions, 0 deletions
diff --git a/python-pyduofern.spec b/python-pyduofern.spec
new file mode 100644
index 0000000..6b4af80
--- /dev/null
+++ b/python-pyduofern.spec
@@ -0,0 +1,176 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyduofern
+Version: 0.35.1
+Release: 1
+Summary: Library for controlling Rademacher DuoFern actors using python. Requires the RademacherDuofern USB Stick Art.-Nr.: 70000093
+License: GPL-2.0
+URL: https://github.com/gluap/pyduofern
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/fb/25/b2f556ee1f02a9147bcbd93d2f7a57aa02b4488ea62e8360af337a8fc573/pyduofern-0.35.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyserial
+Requires: python3-pyserial-asyncio
+
+%description
+**Disclaimer:** this library is **not** endorsed by the company Rademacher, the manufacturer of home automation products
+under the label duofern. The name pyduofern was chosen to indicate the function of the library: communicating with
+duofern devices via python.
+These are my efforts in porting the `FHEM <http://fhem.de/fhem.html>`_
+`Duofern USB-Stick <https://wiki.fhem.de/wiki/DUOFERN>`_ based module to
+`Homeassistant <https://home-assistant.io/>`_. As of now the port is rather ugly, but it is usable enough to control
+my Duofern blinds. I did not port the Weather-Station related features of the original module -- Mainly because I
+do not own the corresponding hardware and have no means to test if it works. I only tested it with the model
+*RolloTron Standard DuoFern 14233011 Funk-Gurtwickler Aufputz*.
+As reported in `#31 <https://github.com/gluap/pyduofern/issues/31>`_ 10-Digit codes recently announced by Rademacher are not supported as of now as the handshake/
+protocol for these devices was not reverse engineered by anyone as far as I know.
+This requires the Duofern USB Stick Art.-Nr.: 70000093 by Rademacher.
+I do not provide any guarantees for the usability of this software. Use at your own risk.
+License::
+ python interface for dufoern usb stick
+ Copyright (C) 2017 Paul Görgen
+ Rough python python translation of the FHEM duofern modules by telekatz
+ (also licensed under GPLv2)
+ This re-write does not literally contain contain any verbatim lines
+ of the original code (given it was translated to another language)
+ apart from some comments to facilitate translation of the not-yet
+ translated parts of the original software. Modification dates are
+ documented as submits to the git repository of this code, currently
+ maintained at `https://github.com/gluap/pyduofern.git <https://github.com/gluap/pyduofern.git>`_
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+
+%package -n python3-pyduofern
+Summary: Library for controlling Rademacher DuoFern actors using python. Requires the RademacherDuofern USB Stick Art.-Nr.: 70000093
+Provides: python-pyduofern
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyduofern
+**Disclaimer:** this library is **not** endorsed by the company Rademacher, the manufacturer of home automation products
+under the label duofern. The name pyduofern was chosen to indicate the function of the library: communicating with
+duofern devices via python.
+These are my efforts in porting the `FHEM <http://fhem.de/fhem.html>`_
+`Duofern USB-Stick <https://wiki.fhem.de/wiki/DUOFERN>`_ based module to
+`Homeassistant <https://home-assistant.io/>`_. As of now the port is rather ugly, but it is usable enough to control
+my Duofern blinds. I did not port the Weather-Station related features of the original module -- Mainly because I
+do not own the corresponding hardware and have no means to test if it works. I only tested it with the model
+*RolloTron Standard DuoFern 14233011 Funk-Gurtwickler Aufputz*.
+As reported in `#31 <https://github.com/gluap/pyduofern/issues/31>`_ 10-Digit codes recently announced by Rademacher are not supported as of now as the handshake/
+protocol for these devices was not reverse engineered by anyone as far as I know.
+This requires the Duofern USB Stick Art.-Nr.: 70000093 by Rademacher.
+I do not provide any guarantees for the usability of this software. Use at your own risk.
+License::
+ python interface for dufoern usb stick
+ Copyright (C) 2017 Paul Görgen
+ Rough python python translation of the FHEM duofern modules by telekatz
+ (also licensed under GPLv2)
+ This re-write does not literally contain contain any verbatim lines
+ of the original code (given it was translated to another language)
+ apart from some comments to facilitate translation of the not-yet
+ translated parts of the original software. Modification dates are
+ documented as submits to the git repository of this code, currently
+ maintained at `https://github.com/gluap/pyduofern.git <https://github.com/gluap/pyduofern.git>`_
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+
+%package help
+Summary: Development documents and examples for pyduofern
+Provides: python3-pyduofern-doc
+%description help
+**Disclaimer:** this library is **not** endorsed by the company Rademacher, the manufacturer of home automation products
+under the label duofern. The name pyduofern was chosen to indicate the function of the library: communicating with
+duofern devices via python.
+These are my efforts in porting the `FHEM <http://fhem.de/fhem.html>`_
+`Duofern USB-Stick <https://wiki.fhem.de/wiki/DUOFERN>`_ based module to
+`Homeassistant <https://home-assistant.io/>`_. As of now the port is rather ugly, but it is usable enough to control
+my Duofern blinds. I did not port the Weather-Station related features of the original module -- Mainly because I
+do not own the corresponding hardware and have no means to test if it works. I only tested it with the model
+*RolloTron Standard DuoFern 14233011 Funk-Gurtwickler Aufputz*.
+As reported in `#31 <https://github.com/gluap/pyduofern/issues/31>`_ 10-Digit codes recently announced by Rademacher are not supported as of now as the handshake/
+protocol for these devices was not reverse engineered by anyone as far as I know.
+This requires the Duofern USB Stick Art.-Nr.: 70000093 by Rademacher.
+I do not provide any guarantees for the usability of this software. Use at your own risk.
+License::
+ python interface for dufoern usb stick
+ Copyright (C) 2017 Paul Görgen
+ Rough python python translation of the FHEM duofern modules by telekatz
+ (also licensed under GPLv2)
+ This re-write does not literally contain contain any verbatim lines
+ of the original code (given it was translated to another language)
+ apart from some comments to facilitate translation of the not-yet
+ translated parts of the original software. Modification dates are
+ documented as submits to the git repository of this code, currently
+ maintained at `https://github.com/gluap/pyduofern.git <https://github.com/gluap/pyduofern.git>`_
+ This program is free software; you can redistribute it and/or modify
+ it under the terms of the GNU General Public License as published by
+ the Free Software Foundation; either version 2 of the License, or
+ (at your option) any later version.
+ This program is distributed in the hope that it will be useful,
+ but WITHOUT ANY WARRANTY; without even the implied warranty of
+ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+ GNU General Public License for more details.
+ You should have received a copy of the GNU General Public License
+ along with this program; if not, write to the Free Software Foundation,
+ Inc., 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA
+
+%prep
+%autosetup -n pyduofern-0.35.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyduofern -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 0.35.1-1
+- Package Spec generated