summaryrefslogtreecommitdiff
path: root/python-pyfirmata.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 23:30:57 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 23:30:57 +0000
commitd5496fd3a06454840af60f110024961d7b99f45a (patch)
treec78b4d40f2ac34574cc86d60963d25fc9dcb4ac4 /python-pyfirmata.spec
parent64f783e196ead94df6ce29a51779c221e611aec2 (diff)
automatic import of python-pyfirmata
Diffstat (limited to 'python-pyfirmata.spec')
-rw-r--r--python-pyfirmata.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-pyfirmata.spec b/python-pyfirmata.spec
new file mode 100644
index 0000000..0c791e3
--- /dev/null
+++ b/python-pyfirmata.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyFirmata
+Version: 1.1.0
+Release: 1
+Summary: A Python interface for the Firmata procotol
+License: MIT License
+URL: https://github.com/tino/pyFirmata
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ff/e6/512cc154c0370e22429db3139e7c906c4f8ad2646f4ca816547e9ae2c26c/pyFirmata-1.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyserial
+
+%description
+
+
+%package -n python3-pyFirmata
+Summary: A Python interface for the Firmata procotol
+Provides: python-pyFirmata
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyFirmata
+
+
+%package help
+Summary: Development documents and examples for pyFirmata
+Provides: python3-pyFirmata-doc
+%description help
+
+
+%prep
+%autosetup -n pyFirmata-1.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyFirmata -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
+- Package Spec generated