summaryrefslogtreecommitdiff
path: root/python-pyflaskbootstrap4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyflaskbootstrap4.spec')
-rw-r--r--python-pyflaskbootstrap4.spec85
1 files changed, 85 insertions, 0 deletions
diff --git a/python-pyflaskbootstrap4.spec b/python-pyflaskbootstrap4.spec
new file mode 100644
index 0000000..5b7fa16
--- /dev/null
+++ b/python-pyflaskbootstrap4.spec
@@ -0,0 +1,85 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyFlaskBootstrap4
+Version: 0.6.1
+Release: 1
+Summary: python flask + Bootstrap 4 static components and templates for webprojects
+License: Apache
+URL: https://github.com/WolfgangFahl/pyFlaskBootstrap4
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/66/a6/7c2dc4d9547842a7fa02832bb6bf166fdd80812190bc0ad0d4c32f1c6696/pyFlaskBootstrap4-0.6.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-Bootstrap-Flask
+Requires: python3-Flask-Dropzone
+Requires: python3-Flask
+Requires: python3-Flask-HTTPAuth
+Requires: python3-Flask-Login
+Requires: python3-Flask-SQLAlchemy
+Requires: python3-Flask-WTF
+Requires: python3-WTForms
+Requires: python3-SQLAlchemy-Utils
+Requires: python3-requests
+Requires: python3-pydevd
+Requires: python3-pyDispatcher
+Requires: python3-APScheduler
+
+%description
+Flask + Bootstrap 4 static components and templates for webprojects
+
+%package -n python3-pyFlaskBootstrap4
+Summary: python flask + Bootstrap 4 static components and templates for webprojects
+Provides: python-pyFlaskBootstrap4
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyFlaskBootstrap4
+Flask + Bootstrap 4 static components and templates for webprojects
+
+%package help
+Summary: Development documents and examples for pyFlaskBootstrap4
+Provides: python3-pyFlaskBootstrap4-doc
+%description help
+Flask + Bootstrap 4 static components and templates for webprojects
+
+%prep
+%autosetup -n pyFlaskBootstrap4-0.6.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyFlaskBootstrap4 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.1-1
+- Package Spec generated