summaryrefslogtreecommitdiff
path: root/python-pygount.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 07:18:42 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 07:18:42 +0000
commit1f32c001f39dbac8ea69acbf9ec47eecea63fbd1 (patch)
tree33b6256c7586a9e0daf37cc754279588c1b5fdf0 /python-pygount.spec
parentd351580a248459b5e25f8f340c211776efab17cb (diff)
automatic import of python-pygount
Diffstat (limited to 'python-pygount.spec')
-rw-r--r--python-pygount.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-pygount.spec b/python-pygount.spec
new file mode 100644
index 0000000..27fe64b
--- /dev/null
+++ b/python-pygount.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pygount
+Version: 1.5.1
+Release: 1
+Summary: count source lines of code (SLOC) using pygments
+License: BSD
+URL: https://github.com/roskakori/pygount
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/51/a5/2285e04702c688b817e7076165b77d4aaa38afc9994f8b1aeedcb29424ce/pygount-1.5.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pygments
+Requires: python3-chardet
+Requires: python3-rich
+
+%description
+Python 19 51.35 1924 72.99 322 86.10
+reStructuredText 7 18.92 332 12.59 7 1.87
+markdown 3 8.11 327 12.41 1 0.27
+Batchfile 1 2.70 24 0.91 1 0.27
+YAML 1 2.70 11 0.42 2 0.53
+Makefile 1 2.70 9 0.34 7 1.87
+INI 1 2.70 5 0.19 0 0.00
+TOML 1 2.70 4 0.15 0 0.00
+
+%package -n python3-pygount
+Summary: count source lines of code (SLOC) using pygments
+Provides: python-pygount
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pygount
+Python 19 51.35 1924 72.99 322 86.10
+reStructuredText 7 18.92 332 12.59 7 1.87
+markdown 3 8.11 327 12.41 1 0.27
+Batchfile 1 2.70 24 0.91 1 0.27
+YAML 1 2.70 11 0.42 2 0.53
+Makefile 1 2.70 9 0.34 7 1.87
+INI 1 2.70 5 0.19 0 0.00
+TOML 1 2.70 4 0.15 0 0.00
+
+%package help
+Summary: Development documents and examples for pygount
+Provides: python3-pygount-doc
+%description help
+Python 19 51.35 1924 72.99 322 86.10
+reStructuredText 7 18.92 332 12.59 7 1.87
+markdown 3 8.11 327 12.41 1 0.27
+Batchfile 1 2.70 24 0.91 1 0.27
+YAML 1 2.70 11 0.42 2 0.53
+Makefile 1 2.70 9 0.34 7 1.87
+INI 1 2.70 5 0.19 0 0.00
+TOML 1 2.70 4 0.15 0 0.00
+
+%prep
+%autosetup -n pygount-1.5.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pygount -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 1.5.1-1
+- Package Spec generated