summaryrefslogtreecommitdiff
path: root/python-pygrok.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pygrok.spec')
-rw-r--r--python-pygrok.spec78
1 files changed, 78 insertions, 0 deletions
diff --git a/python-pygrok.spec b/python-pygrok.spec
new file mode 100644
index 0000000..0676109
--- /dev/null
+++ b/python-pygrok.spec
@@ -0,0 +1,78 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pygrok
+Version: 1.0.0
+Release: 1
+Summary: A Python library to parse strings and extract information from structured/unstructured data
+License: MIT
+URL: https://github.com/garyelephant/pygrok
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ce/a5/963d78c4eda7edb0ea827679dbcf5f77e4d767562b59681bd23ea5913af6/pygrok-1.0.0.tar.gz
+BuildArch: noarch
+
+
+%description
+|Join the chat at https://gitter.im/garyelephant/pygrok|
+A Python library to parse strings and extract information from
+structured/unstructured data
+
+%package -n python3-pygrok
+Summary: A Python library to parse strings and extract information from structured/unstructured data
+Provides: python-pygrok
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pygrok
+|Join the chat at https://gitter.im/garyelephant/pygrok|
+A Python library to parse strings and extract information from
+structured/unstructured data
+
+%package help
+Summary: Development documents and examples for pygrok
+Provides: python3-pygrok-doc
+%description help
+|Join the chat at https://gitter.im/garyelephant/pygrok|
+A Python library to parse strings and extract information from
+structured/unstructured data
+
+%prep
+%autosetup -n pygrok-1.0.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pygrok -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.0-1
+- Package Spec generated