summaryrefslogtreecommitdiff
path: root/python-pykat.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pykat.spec')
-rw-r--r--python-pykat.spec129
1 files changed, 129 insertions, 0 deletions
diff --git a/python-pykat.spec b/python-pykat.spec
new file mode 100644
index 0000000..4e0b499
--- /dev/null
+++ b/python-pykat.spec
@@ -0,0 +1,129 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyKat
+Version: 1.2.94
+Release: 1
+Summary: Python interface and tools for FINESSE
+License: GPL v2
+URL: http://pypi.python.org/pypi/PyKat/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/20/3d/1ff38b347cf4d0c7949908352c0b38690502f9920ef04b47b6dd82fbdafb/PyKat-1.2.94.tar.gz
+BuildArch: noarch
+
+
+%description
+PyKat is a wrapper for using FINESSE (http://www.gwoptics.org/finesse).
+It aims to provide a Python toolset for automating more complex tasks
+as well as providing a GUI for manipulating and viewing simulation
+setups.
+An article is available providing an overview of pykat: https://doi.org/10.1016/j.softx.2020.100613
+Source code is hosted at https://git.ligo.org/finesse/pykat
+Please cite pykat when used with::
+ @article{BROWN_PYKAT,
+ title = "Pykat: Python package for modelling precision optical interferometers",
+ journal = "SoftwareX",
+ volume = "12",
+ pages = "100613",
+ year = "2020",
+ issn = "2352-7110",
+ doi = "https://doi.org/10.1016/j.softx.2020.100613",
+ url = "http://www.sciencedirect.com/science/article/pii/S2352711020303265",
+ author = "Daniel D. Brown and Philip Jones and Samuel Rowlinson and Sean Leavey and Anna C. Green and Daniel Toyra and Andreas Freise",
+ }
+Examples and tutorials can be found at http://www.gwoptics.org/learn/
+Please email `finesse-support@nikhef.nl` if you have any issues.
+
+%package -n python3-PyKat
+Summary: Python interface and tools for FINESSE
+Provides: python-PyKat
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-PyKat
+PyKat is a wrapper for using FINESSE (http://www.gwoptics.org/finesse).
+It aims to provide a Python toolset for automating more complex tasks
+as well as providing a GUI for manipulating and viewing simulation
+setups.
+An article is available providing an overview of pykat: https://doi.org/10.1016/j.softx.2020.100613
+Source code is hosted at https://git.ligo.org/finesse/pykat
+Please cite pykat when used with::
+ @article{BROWN_PYKAT,
+ title = "Pykat: Python package for modelling precision optical interferometers",
+ journal = "SoftwareX",
+ volume = "12",
+ pages = "100613",
+ year = "2020",
+ issn = "2352-7110",
+ doi = "https://doi.org/10.1016/j.softx.2020.100613",
+ url = "http://www.sciencedirect.com/science/article/pii/S2352711020303265",
+ author = "Daniel D. Brown and Philip Jones and Samuel Rowlinson and Sean Leavey and Anna C. Green and Daniel Toyra and Andreas Freise",
+ }
+Examples and tutorials can be found at http://www.gwoptics.org/learn/
+Please email `finesse-support@nikhef.nl` if you have any issues.
+
+%package help
+Summary: Development documents and examples for PyKat
+Provides: python3-PyKat-doc
+%description help
+PyKat is a wrapper for using FINESSE (http://www.gwoptics.org/finesse).
+It aims to provide a Python toolset for automating more complex tasks
+as well as providing a GUI for manipulating and viewing simulation
+setups.
+An article is available providing an overview of pykat: https://doi.org/10.1016/j.softx.2020.100613
+Source code is hosted at https://git.ligo.org/finesse/pykat
+Please cite pykat when used with::
+ @article{BROWN_PYKAT,
+ title = "Pykat: Python package for modelling precision optical interferometers",
+ journal = "SoftwareX",
+ volume = "12",
+ pages = "100613",
+ year = "2020",
+ issn = "2352-7110",
+ doi = "https://doi.org/10.1016/j.softx.2020.100613",
+ url = "http://www.sciencedirect.com/science/article/pii/S2352711020303265",
+ author = "Daniel D. Brown and Philip Jones and Samuel Rowlinson and Sean Leavey and Anna C. Green and Daniel Toyra and Andreas Freise",
+ }
+Examples and tutorials can be found at http://www.gwoptics.org/learn/
+Please email `finesse-support@nikhef.nl` if you have any issues.
+
+%prep
+%autosetup -n PyKat-1.2.94
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyKat -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.94-1
+- Package Spec generated