summaryrefslogtreecommitdiff
path: root/python-pykerberos.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 15:46:34 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 15:46:34 +0000
commitd9d620f86ebb7999cb271ce98789c06956dba77e (patch)
tree30bdbb5771137237eaebcba59ba50dad86d8bda5 /python-pykerberos.spec
parent14e3948274db510a58db81bd857a86c47ada2689 (diff)
automatic import of python-pykerberos
Diffstat (limited to 'python-pykerberos.spec')
-rw-r--r--python-pykerberos.spec96
1 files changed, 96 insertions, 0 deletions
diff --git a/python-pykerberos.spec b/python-pykerberos.spec
new file mode 100644
index 0000000..8ccef3a
--- /dev/null
+++ b/python-pykerberos.spec
@@ -0,0 +1,96 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pykerberos
+Version: 1.2.4
+Release: 1
+Summary: High-level interface to Kerberos
+License: ASL 2.0
+URL: https://github.com/02strich/pykerberos
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/07/e9/ae44ea7d7605df9e5ca1ed745a2c5672dc838a8398101051dd5f255b130d/pykerberos-1.2.4.tar.gz
+BuildArch: noarch
+
+
+%description
+
+This Python package is a high-level wrapper for Kerberos (GSSAPI) operations.
+The goal is to avoid having to build a module that wraps the entire Kerberos.framework,
+and instead offer a limited set of functions that do what is needed for client/server
+Kerberos authentication based on <http://www.ietf.org/rfc/rfc4559.txt>.
+
+
+
+
+
+%package -n python3-pykerberos
+Summary: High-level interface to Kerberos
+Provides: python-pykerberos
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pykerberos
+
+This Python package is a high-level wrapper for Kerberos (GSSAPI) operations.
+The goal is to avoid having to build a module that wraps the entire Kerberos.framework,
+and instead offer a limited set of functions that do what is needed for client/server
+Kerberos authentication based on <http://www.ietf.org/rfc/rfc4559.txt>.
+
+
+
+
+
+%package help
+Summary: Development documents and examples for pykerberos
+Provides: python3-pykerberos-doc
+%description help
+
+This Python package is a high-level wrapper for Kerberos (GSSAPI) operations.
+The goal is to avoid having to build a module that wraps the entire Kerberos.framework,
+and instead offer a limited set of functions that do what is needed for client/server
+Kerberos authentication based on <http://www.ietf.org/rfc/rfc4559.txt>.
+
+
+
+
+
+%prep
+%autosetup -n pykerberos-1.2.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pykerberos -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.2.4-1
+- Package Spec generated