summaryrefslogtreecommitdiff
path: root/python-pymesos.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-12 00:40:16 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-12 00:40:16 +0000
commitef9b4e4fc67cb0bcbc22261b929f5a45634b5147 (patch)
tree491028d3d31a2356beaf6f0d4bf28b0dd894b3b4 /python-pymesos.spec
parentc8ffb7594d22e18f9347b8a3ebb9a4916afc4a78 (diff)
automatic import of python-pymesos
Diffstat (limited to 'python-pymesos.spec')
-rw-r--r--python-pymesos.spec72
1 files changed, 72 insertions, 0 deletions
diff --git a/python-pymesos.spec b/python-pymesos.spec
new file mode 100644
index 0000000..7de489d
--- /dev/null
+++ b/python-pymesos.spec
@@ -0,0 +1,72 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pymesos
+Version: 0.3.15
+Release: 1
+Summary: A pure python implementation of Mesos scheduler and executor
+License: BSD License
+URL: https://github.com/douban/pymesos
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/77/035e81f613d97d313ec69700fbbcc06349e07530a213844667ad37d96c4b/pymesos-0.3.15.tar.gz
+BuildArch: noarch
+
+
+%description
+
+
+%package -n python3-pymesos
+Summary: A pure python implementation of Mesos scheduler and executor
+Provides: python-pymesos
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pymesos
+
+
+%package help
+Summary: Development documents and examples for pymesos
+Provides: python3-pymesos-doc
+%description help
+
+
+%prep
+%autosetup -n pymesos-0.3.15
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pymesos -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed Apr 12 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.15-1
+- Package Spec generated