summaryrefslogtreecommitdiff
path: root/python-pymiscutils.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 17:47:11 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 17:47:11 +0000
commit471050259edf11ce3382e68f1af6a90b552724e8 (patch)
tree728cd44534950596abe3089edb4625135f7f514a /python-pymiscutils.spec
parent83ba73e855f0bd6f8cf9f2497d6a57587c491da5 (diff)
automatic import of python-pymiscutils
Diffstat (limited to 'python-pymiscutils.spec')
-rw-r--r--python-pymiscutils.spec86
1 files changed, 86 insertions, 0 deletions
diff --git a/python-pymiscutils.spec b/python-pymiscutils.spec
new file mode 100644
index 0000000..3aec5c3
--- /dev/null
+++ b/python-pymiscutils.spec
@@ -0,0 +1,86 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pymiscutils
+Version: 0.3.14
+Release: 1
+Summary: Provides a wide range of useful classes and functions.
+License: MIT
+URL: https://github.com/matthewgdv/miscutils
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/cf/7c/73c1182e7e447a878a9c27000490ccb8cca54f4f1d6d67da9c5817b6cf79/pymiscutils-0.3.14.tar.gz
+BuildArch: noarch
+
+Requires: python3-numpy
+Requires: python3-colorama
+Requires: python3-cryptography
+Requires: python3-cursor
+Requires: python3-dill
+Requires: python3-gender-guesser
+Requires: python3-maybe-else
+Requires: python3-pathmagic
+Requires: python3-readchar
+Requires: python3-pysubtypes
+Requires: python3-pyinstrument
+
+%description
+This library is currently still under development. The API will likely undergo significant changes that may break any code you write with it.
+The documentation will fall out of sync with the updates regularly until development slows down. Use it at your own risk.
+
+%package -n python3-pymiscutils
+Summary: Provides a wide range of useful classes and functions.
+Provides: python-pymiscutils
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pymiscutils
+This library is currently still under development. The API will likely undergo significant changes that may break any code you write with it.
+The documentation will fall out of sync with the updates regularly until development slows down. Use it at your own risk.
+
+%package help
+Summary: Development documents and examples for pymiscutils
+Provides: python3-pymiscutils-doc
+%description help
+This library is currently still under development. The API will likely undergo significant changes that may break any code you write with it.
+The documentation will fall out of sync with the updates regularly until development slows down. Use it at your own risk.
+
+%prep
+%autosetup -n pymiscutils-0.3.14
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pymiscutils -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.3.14-1
+- Package Spec generated