summaryrefslogtreecommitdiff
path: root/python-pymsgbox.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pymsgbox.spec')
-rw-r--r--python-pymsgbox.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/python-pymsgbox.spec b/python-pymsgbox.spec
new file mode 100644
index 0000000..8f223b7
--- /dev/null
+++ b/python-pymsgbox.spec
@@ -0,0 +1,114 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyMsgBox
+Version: 1.0.9
+Release: 1
+Summary: A simple, cross-platform, pure Python module for JavaScript-like message boxes.
+License: GPLv3+
+URL: https://github.com/asweigart/pymsgbox
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/7d/ff/4c6f31a4f08979f12a663f2aeb6c8b765d3bd592e66eaaac445f547bb875/PyMsgBox-1.0.9.tar.gz
+BuildArch: noarch
+
+
+%description
+ A simple, cross-platform, pure Python module for JavaScript-like message boxes.
+To import, run:
+ >>> from pymsgbox import *`
+ There are four functions in PyMsgBox, which follow JavaScript's message box naming conventions:
+ >>> alert(text='', title='', button='OK')`
+ Displays a simple message box with text and a single OK button. Returns the text of the button clicked on.
+ >>> confirm(text='', title='', buttons=['OK', 'Cancel'])`
+ Displays a message box with OK and Cancel buttons. Number and text of buttons can be customized. Returns the text of the button clicked on.
+ >>> prompt(text='', title='' , defaultValue='')`
+ Displays a message box with text input, and OK & Cancel buttons. Returns the text entered, or None if Cancel was clicked.
+ >>> password(text='', title='', defaultValue='', mask='*')`
+ Displays a message box with text input, and OK & Cancel buttons. Typed characters appear as *. Returns the text entered, or None if Cancel was clicked.
+On Linux Python 2, you need to first install Tkinter by running: sudo apt-get install python-tk
+Modified BSD License
+Derived from Stephen Raymond Ferg's EasyGui http://easygui.sourceforge.net/
+
+%package -n python3-PyMsgBox
+Summary: A simple, cross-platform, pure Python module for JavaScript-like message boxes.
+Provides: python-PyMsgBox
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-PyMsgBox
+ A simple, cross-platform, pure Python module for JavaScript-like message boxes.
+To import, run:
+ >>> from pymsgbox import *`
+ There are four functions in PyMsgBox, which follow JavaScript's message box naming conventions:
+ >>> alert(text='', title='', button='OK')`
+ Displays a simple message box with text and a single OK button. Returns the text of the button clicked on.
+ >>> confirm(text='', title='', buttons=['OK', 'Cancel'])`
+ Displays a message box with OK and Cancel buttons. Number and text of buttons can be customized. Returns the text of the button clicked on.
+ >>> prompt(text='', title='' , defaultValue='')`
+ Displays a message box with text input, and OK & Cancel buttons. Returns the text entered, or None if Cancel was clicked.
+ >>> password(text='', title='', defaultValue='', mask='*')`
+ Displays a message box with text input, and OK & Cancel buttons. Typed characters appear as *. Returns the text entered, or None if Cancel was clicked.
+On Linux Python 2, you need to first install Tkinter by running: sudo apt-get install python-tk
+Modified BSD License
+Derived from Stephen Raymond Ferg's EasyGui http://easygui.sourceforge.net/
+
+%package help
+Summary: Development documents and examples for PyMsgBox
+Provides: python3-PyMsgBox-doc
+%description help
+ A simple, cross-platform, pure Python module for JavaScript-like message boxes.
+To import, run:
+ >>> from pymsgbox import *`
+ There are four functions in PyMsgBox, which follow JavaScript's message box naming conventions:
+ >>> alert(text='', title='', button='OK')`
+ Displays a simple message box with text and a single OK button. Returns the text of the button clicked on.
+ >>> confirm(text='', title='', buttons=['OK', 'Cancel'])`
+ Displays a message box with OK and Cancel buttons. Number and text of buttons can be customized. Returns the text of the button clicked on.
+ >>> prompt(text='', title='' , defaultValue='')`
+ Displays a message box with text input, and OK & Cancel buttons. Returns the text entered, or None if Cancel was clicked.
+ >>> password(text='', title='', defaultValue='', mask='*')`
+ Displays a message box with text input, and OK & Cancel buttons. Typed characters appear as *. Returns the text entered, or None if Cancel was clicked.
+On Linux Python 2, you need to first install Tkinter by running: sudo apt-get install python-tk
+Modified BSD License
+Derived from Stephen Raymond Ferg's EasyGui http://easygui.sourceforge.net/
+
+%prep
+%autosetup -n PyMsgBox-1.0.9
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyMsgBox -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.9-1
+- Package Spec generated