summaryrefslogtreecommitdiff
path: root/python-pyobjc-framework-pushkit.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 02:12:32 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 02:12:32 +0000
commit23bed73583d557476468cbcac2bc832465e25fc2 (patch)
tree1fecc4c98bde47204d02eee648ba35db6f5f7cb5 /python-pyobjc-framework-pushkit.spec
parent076bea73fa96dbb69942d072dbcc27cf399d754d (diff)
automatic import of python-pyobjc-framework-pushkit
Diffstat (limited to 'python-pyobjc-framework-pushkit.spec')
-rw-r--r--python-pyobjc-framework-pushkit.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-pyobjc-framework-pushkit.spec b/python-pyobjc-framework-pushkit.spec
new file mode 100644
index 0000000..46e725e
--- /dev/null
+++ b/python-pyobjc-framework-pushkit.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyobjc-framework-PushKit
+Version: 9.0.1
+Release: 1
+Summary: Wrappers for the framework PushKit on macOS
+License: MIT License
+URL: https://github.com/ronaldoussoren/pyobjc
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ca/43/b62a203ee0a87f605916120905d7014c6633c78003722e6c00d1b957e996/pyobjc-framework-PushKit-9.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyobjc-core
+Requires: python3-pyobjc-framework-Cocoa
+
+%description
+* `Documentation <https://pyobjc.readthedocs.io/en/latest/>`_
+* `Issue Tracker <https://github.com/ronaldoussoren/pyobjc/issues>`_
+* `Repository <https://github.com/ronaldoussoren/pyobjc/>`_
+
+%package -n python3-pyobjc-framework-PushKit
+Summary: Wrappers for the framework PushKit on macOS
+Provides: python-pyobjc-framework-PushKit
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyobjc-framework-PushKit
+* `Documentation <https://pyobjc.readthedocs.io/en/latest/>`_
+* `Issue Tracker <https://github.com/ronaldoussoren/pyobjc/issues>`_
+* `Repository <https://github.com/ronaldoussoren/pyobjc/>`_
+
+%package help
+Summary: Development documents and examples for pyobjc-framework-PushKit
+Provides: python3-pyobjc-framework-PushKit-doc
+%description help
+* `Documentation <https://pyobjc.readthedocs.io/en/latest/>`_
+* `Issue Tracker <https://github.com/ronaldoussoren/pyobjc/issues>`_
+* `Repository <https://github.com/ronaldoussoren/pyobjc/>`_
+
+%prep
+%autosetup -n pyobjc-framework-PushKit-9.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyobjc-framework-PushKit -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 9.0.1-1
+- Package Spec generated