summaryrefslogtreecommitdiff
path: root/python-pyobjc-framework-screentime.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 22:18:44 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 22:18:44 +0000
commit572514c91bf9683e6294c4b6c8b39a354feb29ea (patch)
tree071bff944818c89a9c52d775ce30a3303f31f635 /python-pyobjc-framework-screentime.spec
parent657dc055ea088badf3892a61dc3a158848a8a6b8 (diff)
automatic import of python-pyobjc-framework-screentime
Diffstat (limited to 'python-pyobjc-framework-screentime.spec')
-rw-r--r--python-pyobjc-framework-screentime.spec80
1 files changed, 80 insertions, 0 deletions
diff --git a/python-pyobjc-framework-screentime.spec b/python-pyobjc-framework-screentime.spec
new file mode 100644
index 0000000..135af25
--- /dev/null
+++ b/python-pyobjc-framework-screentime.spec
@@ -0,0 +1,80 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyobjc-framework-ScreenTime
+Version: 9.0.1
+Release: 1
+Summary: Wrappers for the framework ScreenTime on macOS
+License: MIT License
+URL: https://github.com/ronaldoussoren/pyobjc
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/99/b2/30d906a4d722b5b2051be3de60fc525b67f5c84131480d0a93f50594e969/pyobjc-framework-ScreenTime-9.0.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-pyobjc-core
+Requires: python3-pyobjc-framework-Cocoa
+
+%description
+* `Documentation <https://pyobjc.readthedocs.io/en/latest/>`_
+* `Issue Tracker <https://github.com/ronaldoussoren/pyobjc/issues>`_
+* `Repository <https://github.com/ronaldoussoren/pyobjc/>`_
+
+%package -n python3-pyobjc-framework-ScreenTime
+Summary: Wrappers for the framework ScreenTime on macOS
+Provides: python-pyobjc-framework-ScreenTime
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyobjc-framework-ScreenTime
+* `Documentation <https://pyobjc.readthedocs.io/en/latest/>`_
+* `Issue Tracker <https://github.com/ronaldoussoren/pyobjc/issues>`_
+* `Repository <https://github.com/ronaldoussoren/pyobjc/>`_
+
+%package help
+Summary: Development documents and examples for pyobjc-framework-ScreenTime
+Provides: python3-pyobjc-framework-ScreenTime-doc
+%description help
+* `Documentation <https://pyobjc.readthedocs.io/en/latest/>`_
+* `Issue Tracker <https://github.com/ronaldoussoren/pyobjc/issues>`_
+* `Repository <https://github.com/ronaldoussoren/pyobjc/>`_
+
+%prep
+%autosetup -n pyobjc-framework-ScreenTime-9.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyobjc-framework-ScreenTime -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 9.0.1-1
+- Package Spec generated