summaryrefslogtreecommitdiff
path: root/python-pyomega.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyomega.spec')
-rw-r--r--python-pyomega.spec141
1 files changed, 141 insertions, 0 deletions
diff --git a/python-pyomega.spec b/python-pyomega.spec
new file mode 100644
index 0000000..78cf658
--- /dev/null
+++ b/python-pyomega.spec
@@ -0,0 +1,141 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyomega
+Version: 0.1.17
+Release: 1
+Summary: A small example package
+License: MIT License
+URL: https://github.com/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/f3/bc/6a98ddcfccf02207d0d313548285abeb71a479e6587ebe136e0f906ee1b0/pyomega-0.1.17.tar.gz
+BuildArch: noarch
+
+
+%description
+# Example Package
+
+This is the OMG package. You can use
+[Github-flavored Markdown](https://guides.github.com/features/mastering-markdown/)
+to write your content.
+
+py -m build
+py setup.py sdist bdist_wheel
+py setup.py sdist upload
+
+py -m twine upload dist/*
+py -m twine upload --skip-existing dist/*
+py -m twine upload --repository testpypi dist/*
+
+py -m twine upload --repository testpypi --skip-existing dist/*
+
+
+py -m pip install --index-url https://test.pypi.org/project/pyomega/0.0.2/ --no-deps pyomega-pyomega
+
+py -m pip install -i https://test.pypi.org/simple/ pyomega==0.0.2
+
+
+
+
+
+%package -n python3-pyomega
+Summary: A small example package
+Provides: python-pyomega
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyomega
+# Example Package
+
+This is the OMG package. You can use
+[Github-flavored Markdown](https://guides.github.com/features/mastering-markdown/)
+to write your content.
+
+py -m build
+py setup.py sdist bdist_wheel
+py setup.py sdist upload
+
+py -m twine upload dist/*
+py -m twine upload --skip-existing dist/*
+py -m twine upload --repository testpypi dist/*
+
+py -m twine upload --repository testpypi --skip-existing dist/*
+
+
+py -m pip install --index-url https://test.pypi.org/project/pyomega/0.0.2/ --no-deps pyomega-pyomega
+
+py -m pip install -i https://test.pypi.org/simple/ pyomega==0.0.2
+
+
+
+
+
+%package help
+Summary: Development documents and examples for pyomega
+Provides: python3-pyomega-doc
+%description help
+# Example Package
+
+This is the OMG package. You can use
+[Github-flavored Markdown](https://guides.github.com/features/mastering-markdown/)
+to write your content.
+
+py -m build
+py setup.py sdist bdist_wheel
+py setup.py sdist upload
+
+py -m twine upload dist/*
+py -m twine upload --skip-existing dist/*
+py -m twine upload --repository testpypi dist/*
+
+py -m twine upload --repository testpypi --skip-existing dist/*
+
+
+py -m pip install --index-url https://test.pypi.org/project/pyomega/0.0.2/ --no-deps pyomega-pyomega
+
+py -m pip install -i https://test.pypi.org/simple/ pyomega==0.0.2
+
+
+
+
+
+%prep
+%autosetup -n pyomega-0.1.17
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyomega -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.17-1
+- Package Spec generated