summaryrefslogtreecommitdiff
path: root/python-pyqt6-networkauth.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 05:42:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 05:42:55 +0000
commita71a92a0380487473dc3cdceed159149670782e9 (patch)
treeb0fda9c4115d02006650a22f659551166931ecbf /python-pyqt6-networkauth.spec
parentc805761b5f366f8643ef8db8fd3fce6e7270c5f3 (diff)
automatic import of python-pyqt6-networkauth
Diffstat (limited to 'python-pyqt6-networkauth.spec')
-rw-r--r--python-pyqt6-networkauth.spec83
1 files changed, 83 insertions, 0 deletions
diff --git a/python-pyqt6-networkauth.spec b/python-pyqt6-networkauth.spec
new file mode 100644
index 0000000..ebbd805
--- /dev/null
+++ b/python-pyqt6-networkauth.spec
@@ -0,0 +1,83 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyQt6-NetworkAuth
+Version: 6.5.0
+Release: 1
+Summary: Python bindings for the Qt Network Authorization library
+License: GPL v3
+URL: https://www.riverbankcomputing.com/software/pyqtnetworkauth/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/dc/7f/2305cdafa48a14cf8f81a75f5d840277cf860cf4cec7afdb9d23d183ebe4/PyQt6_NetworkAuth-6.5.0.tar.gz
+
+Requires: python3-PyQt6-sip
+Requires: python3-PyQt6-NetworkAuth-Qt6
+Requires: python3-PyQt6
+
+%description
+PyQt6-NetworkAuth is a set of Python bindings for The Qt Company's Qt Network
+Authorisation library. The bindings sit on top of PyQt6 and are implemented as
+a single module.
+
+%package -n python3-PyQt6-NetworkAuth
+Summary: Python bindings for the Qt Network Authorization library
+Provides: python-PyQt6-NetworkAuth
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-PyQt6-NetworkAuth
+PyQt6-NetworkAuth is a set of Python bindings for The Qt Company's Qt Network
+Authorisation library. The bindings sit on top of PyQt6 and are implemented as
+a single module.
+
+%package help
+Summary: Development documents and examples for PyQt6-NetworkAuth
+Provides: python3-PyQt6-NetworkAuth-doc
+%description help
+PyQt6-NetworkAuth is a set of Python bindings for The Qt Company's Qt Network
+Authorisation library. The bindings sit on top of PyQt6 and are implemented as
+a single module.
+
+%prep
+%autosetup -n PyQt6-NetworkAuth-6.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyQt6-NetworkAuth -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 6.5.0-1
+- Package Spec generated