summaryrefslogtreecommitdiff
path: root/python-pyqt6.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 05:41:24 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 05:41:24 +0000
commit4239f4c2e64ee81018415508709db5955c57ba54 (patch)
tree5cc13f04d7873a17ef1d2d64e94128ed3da33b62 /python-pyqt6.spec
parent52296b4bedfe89ba0b543568775314915fa745d7 (diff)
automatic import of python-pyqt6
Diffstat (limited to 'python-pyqt6.spec')
-rw-r--r--python-pyqt6.spec103
1 files changed, 103 insertions, 0 deletions
diff --git a/python-pyqt6.spec b/python-pyqt6.spec
new file mode 100644
index 0000000..cbf04a5
--- /dev/null
+++ b/python-pyqt6.spec
@@ -0,0 +1,103 @@
+%global _empty_manifest_terminate_build 0
+Name: python-PyQt6
+Version: 6.5.0
+Release: 1
+Summary: Python bindings for the Qt cross platform application toolkit
+License: GPL v3
+URL: https://www.riverbankcomputing.com/software/pyqt/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/28/01/9e4b91cb0c1023934b1dc654c5bbfc29cbabcbf6092f936b74aee46dd637/PyQt6-6.5.0.tar.gz
+
+Requires: python3-PyQt6-sip
+Requires: python3-PyQt6-Qt6
+
+%description
+Qt is set of cross-platform C++ libraries that implement high-level APIs for
+accessing many aspects of modern desktop and mobile systems. These include
+location and positioning services, multimedia, NFC and Bluetooth connectivity,
+a Chromium based web browser, as well as traditional UI development.
+PyQt6 is a comprehensive set of Python bindings for Qt v6. It is implemented
+as more than 35 extension modules and enables Python to be used as an
+alternative application development language to C++ on all supported platforms
+including iOS and Android.
+PyQt6 may also be embedded in C++ based applications to allow users of those
+applications to configure or enhance the functionality of those applications.
+
+%package -n python3-PyQt6
+Summary: Python bindings for the Qt cross platform application toolkit
+Provides: python-PyQt6
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-PyQt6
+Qt is set of cross-platform C++ libraries that implement high-level APIs for
+accessing many aspects of modern desktop and mobile systems. These include
+location and positioning services, multimedia, NFC and Bluetooth connectivity,
+a Chromium based web browser, as well as traditional UI development.
+PyQt6 is a comprehensive set of Python bindings for Qt v6. It is implemented
+as more than 35 extension modules and enables Python to be used as an
+alternative application development language to C++ on all supported platforms
+including iOS and Android.
+PyQt6 may also be embedded in C++ based applications to allow users of those
+applications to configure or enhance the functionality of those applications.
+
+%package help
+Summary: Development documents and examples for PyQt6
+Provides: python3-PyQt6-doc
+%description help
+Qt is set of cross-platform C++ libraries that implement high-level APIs for
+accessing many aspects of modern desktop and mobile systems. These include
+location and positioning services, multimedia, NFC and Bluetooth connectivity,
+a Chromium based web browser, as well as traditional UI development.
+PyQt6 is a comprehensive set of Python bindings for Qt v6. It is implemented
+as more than 35 extension modules and enables Python to be used as an
+alternative application development language to C++ on all supported platforms
+including iOS and Android.
+PyQt6 may also be embedded in C++ based applications to allow users of those
+applications to configure or enhance the functionality of those applications.
+
+%prep
+%autosetup -n PyQt6-6.5.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-PyQt6 -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 6.5.0-1
+- Package Spec generated