summaryrefslogtreecommitdiff
path: root/python-pyreferrer.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pyreferrer.spec')
-rw-r--r--python-pyreferrer.spec75
1 files changed, 75 insertions, 0 deletions
diff --git a/python-pyreferrer.spec b/python-pyreferrer.spec
new file mode 100644
index 0000000..1dd9ae4
--- /dev/null
+++ b/python-pyreferrer.spec
@@ -0,0 +1,75 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyreferrer
+Version: 0.6.6
+Release: 1
+Summary: A referrer parser for Python.
+License: MIT
+URL: http://github.com/Shopify/pyreferrer
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/95/d0/dfcd516508d1cdbdd3a6016d01599251bbe51f89ac6da96286eb9d5f130d/pyreferrer-0.6.6.tar.gz
+BuildArch: noarch
+
+Requires: python3-tldextract
+Requires: python3-six
+Requires: python3-nose
+
+%description
+
+
+%package -n python3-pyreferrer
+Summary: A referrer parser for Python.
+Provides: python-pyreferrer
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyreferrer
+
+
+%package help
+Summary: Development documents and examples for pyreferrer
+Provides: python3-pyreferrer-doc
+%description help
+
+
+%prep
+%autosetup -n pyreferrer-0.6.6
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyreferrer -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.6-1
+- Package Spec generated