summaryrefslogtreecommitdiff
path: root/python-pysubs2.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pysubs2.spec')
-rw-r--r--python-pysubs2.spec120
1 files changed, 120 insertions, 0 deletions
diff --git a/python-pysubs2.spec b/python-pysubs2.spec
new file mode 100644
index 0000000..59a8012
--- /dev/null
+++ b/python-pysubs2.spec
@@ -0,0 +1,120 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pysubs2
+Version: 1.6.1
+Release: 1
+Summary: A library for editing subtitle files
+License: MIT
+URL: https://github.com/tkarabela/pysubs2
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/22/3e/fb1b08a06144ba63f19cc4758dd72e2eb8c7fc95c6c8364faccfc570c7bf/pysubs2-1.6.1.tar.gz
+BuildArch: noarch
+
+
+%description
+pysubs2 is a Python library for editing subtitle files.
+It’s based on *SubStation Alpha*, the native format of
+`Aegisub <http://www.aegisub.org/>`_; it also supports *SubRip (SRT)*,
+*MicroDVD*, *MPL2*, *TMP* and *WebVTT* formats and *OpenAI Whisper* captions.
+There is a small CLI tool for batch conversion and retiming.
+ $ pip install pysubs2
+ $ pysubs2 --shift 0.3s *.srt
+ $ pysubs2 --to srt *.ass
+ import pysubs2
+ subs = pysubs2.load("my_subtitles.ass", encoding="utf-8")
+ subs.shift(s=2.5)
+ for line in subs:
+ line.text = "{\\be1}" + line.text
+ subs.save("my_subtitles_edited.ass")
+To learn more, please `see the documentation <http://pysubs2.readthedocs.io>`_.
+If you'd like to contribute, see `CONTRIBUTING.md <CONTRIBUTING.md>`_.
+pysubs2 is licensed under the MIT license (see `LICENSE.txt <LICENSE.txt>`_).
+
+%package -n python3-pysubs2
+Summary: A library for editing subtitle files
+Provides: python-pysubs2
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pysubs2
+pysubs2 is a Python library for editing subtitle files.
+It’s based on *SubStation Alpha*, the native format of
+`Aegisub <http://www.aegisub.org/>`_; it also supports *SubRip (SRT)*,
+*MicroDVD*, *MPL2*, *TMP* and *WebVTT* formats and *OpenAI Whisper* captions.
+There is a small CLI tool for batch conversion and retiming.
+ $ pip install pysubs2
+ $ pysubs2 --shift 0.3s *.srt
+ $ pysubs2 --to srt *.ass
+ import pysubs2
+ subs = pysubs2.load("my_subtitles.ass", encoding="utf-8")
+ subs.shift(s=2.5)
+ for line in subs:
+ line.text = "{\\be1}" + line.text
+ subs.save("my_subtitles_edited.ass")
+To learn more, please `see the documentation <http://pysubs2.readthedocs.io>`_.
+If you'd like to contribute, see `CONTRIBUTING.md <CONTRIBUTING.md>`_.
+pysubs2 is licensed under the MIT license (see `LICENSE.txt <LICENSE.txt>`_).
+
+%package help
+Summary: Development documents and examples for pysubs2
+Provides: python3-pysubs2-doc
+%description help
+pysubs2 is a Python library for editing subtitle files.
+It’s based on *SubStation Alpha*, the native format of
+`Aegisub <http://www.aegisub.org/>`_; it also supports *SubRip (SRT)*,
+*MicroDVD*, *MPL2*, *TMP* and *WebVTT* formats and *OpenAI Whisper* captions.
+There is a small CLI tool for batch conversion and retiming.
+ $ pip install pysubs2
+ $ pysubs2 --shift 0.3s *.srt
+ $ pysubs2 --to srt *.ass
+ import pysubs2
+ subs = pysubs2.load("my_subtitles.ass", encoding="utf-8")
+ subs.shift(s=2.5)
+ for line in subs:
+ line.text = "{\\be1}" + line.text
+ subs.save("my_subtitles_edited.ass")
+To learn more, please `see the documentation <http://pysubs2.readthedocs.io>`_.
+If you'd like to contribute, see `CONTRIBUTING.md <CONTRIBUTING.md>`_.
+pysubs2 is licensed under the MIT license (see `LICENSE.txt <LICENSE.txt>`_).
+
+%prep
+%autosetup -n pysubs2-1.6.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pysubs2 -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.1-1
+- Package Spec generated