summaryrefslogtreecommitdiff
path: root/python-pytest-codestyle.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytest-codestyle.spec')
-rw-r--r--python-pytest-codestyle.spec198
1 files changed, 198 insertions, 0 deletions
diff --git a/python-pytest-codestyle.spec b/python-pytest-codestyle.spec
new file mode 100644
index 0000000..70e98cd
--- /dev/null
+++ b/python-pytest-codestyle.spec
@@ -0,0 +1,198 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-codestyle
+Version: 2.0.1
+Release: 1
+Summary: pytest plugin to run pycodestyle
+License: MIT
+URL: https://github.com/henry0312/pytest-codestyle
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/81/4a/2cfc856035c87b6b600fe86bfd430615c89737b5e43808453a47f5d22536/pytest-codestyle-2.0.1.tar.gz
+BuildArch: noarch
+
+
+%description
+# pytest-codestyle
+
+[![PyPI version](https://badge.fury.io/py/pytest-codestyle.svg)](https://pypi.org/project/pytest-codestyle/)
+
+[pytest](https://docs.pytest.org/en/latest/) plugin to run [pycodestyle](https://github.com/PyCQA/pycodestyle)
+
+## Installation
+
+```sh
+pip install pytest-codestyle
+```
+
+## Usage
+
+```sh
+pytest --pycodestyle ...
+```
+
+For detail, please see `pytest -h` after installation.
+
+## Configuration
+
+The behavior can be configured in the same style of pycodestyle.
+(cf. [Configuration — pytest documentation](https://docs.pytest.org/en/latest/customize.html) and [Configuration — pycodestyle documentation](https://pycodestyle.readthedocs.io/en/latest/intro.html#configuration))
+
+For example,
+
+```
+[pycodestyle]
+max-line-length = 127
+
+[tool:pytest]
+addopts = --pycodestyle
+```
+
+## Licence
+
+The MIT License
+Copyright (c) 2019 OMOTO Tsukasa
+
+## Acknowledgments
+
+- [pytest-dev / pytest-pep8 — Bitbucket](https://bitbucket.org/pytest-dev/pytest-pep8)
+
+%package -n python3-pytest-codestyle
+Summary: pytest plugin to run pycodestyle
+Provides: python-pytest-codestyle
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-codestyle
+# pytest-codestyle
+
+[![PyPI version](https://badge.fury.io/py/pytest-codestyle.svg)](https://pypi.org/project/pytest-codestyle/)
+
+[pytest](https://docs.pytest.org/en/latest/) plugin to run [pycodestyle](https://github.com/PyCQA/pycodestyle)
+
+## Installation
+
+```sh
+pip install pytest-codestyle
+```
+
+## Usage
+
+```sh
+pytest --pycodestyle ...
+```
+
+For detail, please see `pytest -h` after installation.
+
+## Configuration
+
+The behavior can be configured in the same style of pycodestyle.
+(cf. [Configuration — pytest documentation](https://docs.pytest.org/en/latest/customize.html) and [Configuration — pycodestyle documentation](https://pycodestyle.readthedocs.io/en/latest/intro.html#configuration))
+
+For example,
+
+```
+[pycodestyle]
+max-line-length = 127
+
+[tool:pytest]
+addopts = --pycodestyle
+```
+
+## Licence
+
+The MIT License
+Copyright (c) 2019 OMOTO Tsukasa
+
+## Acknowledgments
+
+- [pytest-dev / pytest-pep8 — Bitbucket](https://bitbucket.org/pytest-dev/pytest-pep8)
+
+%package help
+Summary: Development documents and examples for pytest-codestyle
+Provides: python3-pytest-codestyle-doc
+%description help
+# pytest-codestyle
+
+[![PyPI version](https://badge.fury.io/py/pytest-codestyle.svg)](https://pypi.org/project/pytest-codestyle/)
+
+[pytest](https://docs.pytest.org/en/latest/) plugin to run [pycodestyle](https://github.com/PyCQA/pycodestyle)
+
+## Installation
+
+```sh
+pip install pytest-codestyle
+```
+
+## Usage
+
+```sh
+pytest --pycodestyle ...
+```
+
+For detail, please see `pytest -h` after installation.
+
+## Configuration
+
+The behavior can be configured in the same style of pycodestyle.
+(cf. [Configuration — pytest documentation](https://docs.pytest.org/en/latest/customize.html) and [Configuration — pycodestyle documentation](https://pycodestyle.readthedocs.io/en/latest/intro.html#configuration))
+
+For example,
+
+```
+[pycodestyle]
+max-line-length = 127
+
+[tool:pytest]
+addopts = --pycodestyle
+```
+
+## Licence
+
+The MIT License
+Copyright (c) 2019 OMOTO Tsukasa
+
+## Acknowledgments
+
+- [pytest-dev / pytest-pep8 — Bitbucket](https://bitbucket.org/pytest-dev/pytest-pep8)
+
+%prep
+%autosetup -n pytest-codestyle-2.0.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-codestyle -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 10 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.1-1
+- Package Spec generated