summaryrefslogtreecommitdiff
path: root/python-pytest-docker-compose.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-10 22:49:56 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-10 22:49:56 +0000
commit8397cc504e7b397ce4a0c781a5d8f4f799566c22 (patch)
treee2f334646dba218306c9d9aa13141fd834cb0bc7 /python-pytest-docker-compose.spec
parent50b78f9a20d712504e7139ac85cc1331b4d3ceab (diff)
automatic import of python-pytest-docker-compose
Diffstat (limited to 'python-pytest-docker-compose.spec')
-rw-r--r--python-pytest-docker-compose.spec77
1 files changed, 77 insertions, 0 deletions
diff --git a/python-pytest-docker-compose.spec b/python-pytest-docker-compose.spec
new file mode 100644
index 0000000..eca20cd
--- /dev/null
+++ b/python-pytest-docker-compose.spec
@@ -0,0 +1,77 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-docker-compose
+Version: 3.2.1
+Release: 1
+Summary: Manages Docker containers during your integration tests
+License: Apache Software License
+URL: https://github.com/pytest-docker-compose/pytest-docker-compose
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/9e/32/ed02afdd0a8730660f2f48f7f48edc24ac942752b6d8b23d6ee5c443ca29/pytest-docker-compose-3.2.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-docker-compose
+Requires: python3-pytest
+
+%description
+This package contains a `pytest`_ plugin for integrating Docker Compose into your automated integration tests.
+Given a path to a ``docker-compose.yml`` file, it will automatically build the project at the start of the test run, bring the containers up before each test starts, and tear them down after each test ends.
+
+%package -n python3-pytest-docker-compose
+Summary: Manages Docker containers during your integration tests
+Provides: python-pytest-docker-compose
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-docker-compose
+This package contains a `pytest`_ plugin for integrating Docker Compose into your automated integration tests.
+Given a path to a ``docker-compose.yml`` file, it will automatically build the project at the start of the test run, bring the containers up before each test starts, and tear them down after each test ends.
+
+%package help
+Summary: Development documents and examples for pytest-docker-compose
+Provides: python3-pytest-docker-compose-doc
+%description help
+This package contains a `pytest`_ plugin for integrating Docker Compose into your automated integration tests.
+Given a path to a ``docker-compose.yml`` file, it will automatically build the project at the start of the test run, bring the containers up before each test starts, and tear them down after each test ends.
+
+%prep
+%autosetup -n pytest-docker-compose-3.2.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-docker-compose -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 3.2.1-1
+- Package Spec generated