summaryrefslogtreecommitdiff
path: root/python-pytest-httpbin.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytest-httpbin.spec')
-rw-r--r--python-pytest-httpbin.spec121
1 files changed, 121 insertions, 0 deletions
diff --git a/python-pytest-httpbin.spec b/python-pytest-httpbin.spec
new file mode 100644
index 0000000..2e93169
--- /dev/null
+++ b/python-pytest-httpbin.spec
@@ -0,0 +1,121 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-httpbin
+Version: 1.0.2
+Release: 1
+Summary: Easily test your HTTP library against a local copy of httpbin
+License: MIT
+URL: https://github.com/kevin1024/pytest-httpbin
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c3/18/4638bf234d6f1e3e540cd0b9c117f0df1b75ef2700af03da2d3c3009026c/pytest-httpbin-1.0.2.tar.gz
+BuildArch: noarch
+
+Requires: python3-httpbin
+Requires: python3-six
+Requires: python3-requests
+Requires: python3-pytest
+
+%description
+httpbin is an amazing web service for testing HTTP libraries. It has several
+great endpoints that can test pretty much everything you need in a HTTP
+library. The only problem is: maybe you don't want to wait for your tests to
+travel across the Internet and back to make assertions against a remote web
+service.
+Enter pytest-httpbin. Pytest-httpbin creates a pytest "fixture" that is
+dependency-injected into your tests. It automatically starts up a HTTP server
+in a separate thread running httpbin and provides your test with the URL in the
+fixture. Check out this example:
+ def test_that_my_library_works_kinda_ok(httpbin):
+ assert requests.get(httpbin.url + '/get/').status_code == 200
+This replaces a test that might have looked like this before:
+ def test_that_my_library_works_kinda_ok():
+ assert requests.get('http://httpbin.org/get').status_code == 200
+pytest-httpbin also supports https and includes its own CA cert you can use.
+Check out `the full documentation`_ on the github page.
+
+%package -n python3-pytest-httpbin
+Summary: Easily test your HTTP library against a local copy of httpbin
+Provides: python-pytest-httpbin
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-httpbin
+httpbin is an amazing web service for testing HTTP libraries. It has several
+great endpoints that can test pretty much everything you need in a HTTP
+library. The only problem is: maybe you don't want to wait for your tests to
+travel across the Internet and back to make assertions against a remote web
+service.
+Enter pytest-httpbin. Pytest-httpbin creates a pytest "fixture" that is
+dependency-injected into your tests. It automatically starts up a HTTP server
+in a separate thread running httpbin and provides your test with the URL in the
+fixture. Check out this example:
+ def test_that_my_library_works_kinda_ok(httpbin):
+ assert requests.get(httpbin.url + '/get/').status_code == 200
+This replaces a test that might have looked like this before:
+ def test_that_my_library_works_kinda_ok():
+ assert requests.get('http://httpbin.org/get').status_code == 200
+pytest-httpbin also supports https and includes its own CA cert you can use.
+Check out `the full documentation`_ on the github page.
+
+%package help
+Summary: Development documents and examples for pytest-httpbin
+Provides: python3-pytest-httpbin-doc
+%description help
+httpbin is an amazing web service for testing HTTP libraries. It has several
+great endpoints that can test pretty much everything you need in a HTTP
+library. The only problem is: maybe you don't want to wait for your tests to
+travel across the Internet and back to make assertions against a remote web
+service.
+Enter pytest-httpbin. Pytest-httpbin creates a pytest "fixture" that is
+dependency-injected into your tests. It automatically starts up a HTTP server
+in a separate thread running httpbin and provides your test with the URL in the
+fixture. Check out this example:
+ def test_that_my_library_works_kinda_ok(httpbin):
+ assert requests.get(httpbin.url + '/get/').status_code == 200
+This replaces a test that might have looked like this before:
+ def test_that_my_library_works_kinda_ok():
+ assert requests.get('http://httpbin.org/get').status_code == 200
+pytest-httpbin also supports https and includes its own CA cert you can use.
+Check out `the full documentation`_ on the github page.
+
+%prep
+%autosetup -n pytest-httpbin-1.0.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-httpbin -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu Mar 09 2023 Python_Bot <Python_Bot@openeuler.org> - 1.0.2-1
+- Package Spec generated