summaryrefslogtreecommitdiff
path: root/python-pytest-incremental.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 22:02:05 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 22:02:05 +0000
commit772c40e8ebf0a9fe47ba0b249add0539047f00f6 (patch)
tree41e97b0bc6f96ba19cad65ee106504d2ecf68ce4 /python-pytest-incremental.spec
parent18c1592cc234a005575f727f30ab1b1bf8081220 (diff)
automatic import of python-pytest-incremental
Diffstat (limited to 'python-pytest-incremental.spec')
-rw-r--r--python-pytest-incremental.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-pytest-incremental.spec b/python-pytest-incremental.spec
new file mode 100644
index 0000000..1176eb8
--- /dev/null
+++ b/python-pytest-incremental.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-incremental
+Version: 0.6.0
+Release: 1
+Summary: an incremental test runner (pytest plugin)
+License: MIT
+URL: https://pytest-incremental.readthedocs.io
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/4b/4f/4b465c32bd40b1bd59ed86c854ae3c36ed6ae3956d182271cd2f254914fc/pytest-incremental-0.6.0.tar.gz
+BuildArch: noarch
+
+
+%description
+an incremental test runner (pytest plug-in)
+*pytest-incremental* analyses your project structure and file
+modifications between test-runs
+to modify the order tests are executed and de-select tests.
+This allows a much faster feedback for interactive test execution.
+
+%package -n python3-pytest-incremental
+Summary: an incremental test runner (pytest plugin)
+Provides: python-pytest-incremental
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-incremental
+an incremental test runner (pytest plug-in)
+*pytest-incremental* analyses your project structure and file
+modifications between test-runs
+to modify the order tests are executed and de-select tests.
+This allows a much faster feedback for interactive test execution.
+
+%package help
+Summary: Development documents and examples for pytest-incremental
+Provides: python3-pytest-incremental-doc
+%description help
+an incremental test runner (pytest plug-in)
+*pytest-incremental* analyses your project structure and file
+modifications between test-runs
+to modify the order tests are executed and de-select tests.
+This allows a much faster feedback for interactive test execution.
+
+%prep
+%autosetup -n pytest-incremental-0.6.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-incremental -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.0-1
+- Package Spec generated