summaryrefslogtreecommitdiff
path: root/python-pytest-random-order.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytest-random-order.spec')
-rw-r--r--python-pytest-random-order.spec73
1 files changed, 73 insertions, 0 deletions
diff --git a/python-pytest-random-order.spec b/python-pytest-random-order.spec
new file mode 100644
index 0000000..093e359
--- /dev/null
+++ b/python-pytest-random-order.spec
@@ -0,0 +1,73 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-random-order
+Version: 1.1.0
+Release: 1
+Summary: Randomise the order in which pytest tests are run with some control over the randomness
+License: MIT
+URL: https://github.com/jbasko/pytest-random-order
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/3d/ef/93dc9fa0b3b7eb99566813bccaf50216ef1c7d8d07923348fabbd6f7eefc/pytest-random-order-1.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytest
+
+%description
+
+
+%package -n python3-pytest-random-order
+Summary: Randomise the order in which pytest tests are run with some control over the randomness
+Provides: python-pytest-random-order
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-random-order
+
+
+%package help
+Summary: Development documents and examples for pytest-random-order
+Provides: python3-pytest-random-order-doc
+%description help
+
+
+%prep
+%autosetup -n pytest-random-order-1.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-random-order -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Mon Apr 10 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
+- Package Spec generated