summaryrefslogtreecommitdiff
path: root/python-pytest-split-tests.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-05 06:09:55 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-05 06:09:55 +0000
commit56decaf6309be98703bca90255dd9de7ba2fa382 (patch)
tree5bd2df7849f527293c5760d64f3151c150219762 /python-pytest-split-tests.spec
parent5460f5984acd27be15bfb2f284e9469477569874 (diff)
automatic import of python-pytest-split-testsopeneuler20.03
Diffstat (limited to 'python-pytest-split-tests.spec')
-rw-r--r--python-pytest-split-tests.spec76
1 files changed, 76 insertions, 0 deletions
diff --git a/python-pytest-split-tests.spec b/python-pytest-split-tests.spec
new file mode 100644
index 0000000..f08d914
--- /dev/null
+++ b/python-pytest-split-tests.spec
@@ -0,0 +1,76 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytest-split-tests
+Version: 1.1.0
+Release: 1
+Summary: A Pytest plugin for running a subset of your tests by splitting them in to equally sized groups. Forked from Mark Adams' original project pytest-test-groups.
+License: MIT License
+URL: https://github.com/wchill/pytest-split-tests
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/2d/01/593bdeff8f521a614ef6f7837983f1d1cf3f07cff565be4a5f349349e9e1/pytest-split-tests-1.1.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-pytest
+
+%description
+pytest-split-tests allows you to split your test runs into groups of a specific
+size to make it easier to split up your test runs.
+
+%package -n python3-pytest-split-tests
+Summary: A Pytest plugin for running a subset of your tests by splitting them in to equally sized groups. Forked from Mark Adams' original project pytest-test-groups.
+Provides: python-pytest-split-tests
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytest-split-tests
+pytest-split-tests allows you to split your test runs into groups of a specific
+size to make it easier to split up your test runs.
+
+%package help
+Summary: Development documents and examples for pytest-split-tests
+Provides: python3-pytest-split-tests-doc
+%description help
+pytest-split-tests allows you to split your test runs into groups of a specific
+size to make it easier to split up your test runs.
+
+%prep
+%autosetup -n pytest-split-tests-1.1.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytest-split-tests -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Fri May 05 2023 Python_Bot <Python_Bot@openeuler.org> - 1.1.0-1
+- Package Spec generated