summaryrefslogtreecommitdiff
path: root/python-pytntprog.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pytntprog.spec')
-rw-r--r--python-pytntprog.spec82
1 files changed, 82 insertions, 0 deletions
diff --git a/python-pytntprog.spec b/python-pytntprog.spec
new file mode 100644
index 0000000..1c8e992
--- /dev/null
+++ b/python-pytntprog.spec
@@ -0,0 +1,82 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pytntprog
+Version: 1.3.0
+Release: 1
+Summary: pytntprog displays the program of tnt tv in France
+License: MIT
+URL: https://github.com/thib1984/pytntprog
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/bc/e7/93a779f135a3a5ba12f17f82886038d757031a44c11af720461b50e87143/pytntprog-1.3.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-colorama
+Requires: python3-termcolor
+Requires: python3-columnar
+Requires: python3-requests
+
+%description
+The complete description/installation/use/FAQ is available at : https://github.com/thib1984/pytntprog#readme
+
+
+
+%package -n python3-pytntprog
+Summary: pytntprog displays the program of tnt tv in France
+Provides: python-pytntprog
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pytntprog
+The complete description/installation/use/FAQ is available at : https://github.com/thib1984/pytntprog#readme
+
+
+
+%package help
+Summary: Development documents and examples for pytntprog
+Provides: python3-pytntprog-doc
+%description help
+The complete description/installation/use/FAQ is available at : https://github.com/thib1984/pytntprog#readme
+
+
+
+%prep
+%autosetup -n pytntprog-1.3.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pytntprog -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.3.0-1
+- Package Spec generated