summaryrefslogtreecommitdiff
path: root/python-pyuwsgi.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-04-11 06:29:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-04-11 06:29:50 +0000
commita24d82b2876bc38410f6383aa568052855672763 (patch)
tree55b0d872615d93e1b7c161d0a50b6bee44c996b4 /python-pyuwsgi.spec
parent9a05585a5e774c7046f75f6510c7c05d91ca72b7 (diff)
automatic import of python-pyuwsgi
Diffstat (limited to 'python-pyuwsgi.spec')
-rw-r--r--python-pyuwsgi.spec81
1 files changed, 81 insertions, 0 deletions
diff --git a/python-pyuwsgi.spec b/python-pyuwsgi.spec
new file mode 100644
index 0000000..e2e2fc7
--- /dev/null
+++ b/python-pyuwsgi.spec
@@ -0,0 +1,81 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyuwsgi
+Version: 2.0.21
+Release: 1
+Summary: The uWSGI server
+License: GPL2
+URL: https://uwsgi-docs.readthedocs.io/en/latest/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a1/3d/d55663eb0640154000804a5dc36e1f50d7948e25fc0ccb3c16577dea3c5b/pyuwsgi-2.0.21.tar.gz
+BuildArch: noarch
+
+
+%description
+[![Lincoln Loop](https://cldup.com/gyNz5rfTkR.png)](https://lincolnloop.com)
+`pyuwsgi` is sponsored by [Lincoln Loop](https://lincolnloop.com).
+[![Unbit](https://cldup.com/TTNag1Zlcw.png)](http://unbit.com/)
+`uwsgi` is the creation of [Unbit](http://unbit.com/).
+
+%package -n python3-pyuwsgi
+Summary: The uWSGI server
+Provides: python-pyuwsgi
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pyuwsgi
+[![Lincoln Loop](https://cldup.com/gyNz5rfTkR.png)](https://lincolnloop.com)
+`pyuwsgi` is sponsored by [Lincoln Loop](https://lincolnloop.com).
+[![Unbit](https://cldup.com/TTNag1Zlcw.png)](http://unbit.com/)
+`uwsgi` is the creation of [Unbit](http://unbit.com/).
+
+%package help
+Summary: Development documents and examples for pyuwsgi
+Provides: python3-pyuwsgi-doc
+%description help
+[![Lincoln Loop](https://cldup.com/gyNz5rfTkR.png)](https://lincolnloop.com)
+`pyuwsgi` is sponsored by [Lincoln Loop](https://lincolnloop.com).
+[![Unbit](https://cldup.com/TTNag1Zlcw.png)](http://unbit.com/)
+`uwsgi` is the creation of [Unbit](http://unbit.com/).
+
+%prep
+%autosetup -n pyuwsgi-2.0.21
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyuwsgi -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Apr 11 2023 Python_Bot <Python_Bot@openeuler.org> - 2.0.21-1
+- Package Spec generated