summaryrefslogtreecommitdiff
path: root/python-pywinhook.spec
diff options
context:
space:
mode:
authorCoprDistGit <infra@openeuler.org>2023-05-31 04:37:50 +0000
committerCoprDistGit <infra@openeuler.org>2023-05-31 04:37:50 +0000
commitf8c9332629e6f5c8644195152b6c91d479991b97 (patch)
tree8711d159683210f47a7f6ee61c077908f523c781 /python-pywinhook.spec
parenta0e26044c6f7e953b77e01ee38d564cc93f1d68a (diff)
automatic import of python-pywinhook
Diffstat (limited to 'python-pywinhook.spec')
-rw-r--r--python-pywinhook.spec84
1 files changed, 84 insertions, 0 deletions
diff --git a/python-pywinhook.spec b/python-pywinhook.spec
new file mode 100644
index 0000000..cf6a2ee
--- /dev/null
+++ b/python-pywinhook.spec
@@ -0,0 +1,84 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pyWinhook
+Version: 1.6.2
+Release: 1
+Summary: A pyHook module fork from Peter P. with some updates.
+License: http://www.opensource.org/licenses/mit-license.php
+URL: https://github.com/Tungsteno74/pyWinhook
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/ce/d1/6dcf4a17f425a5e3e2c011bac622dacae3128e96fd038b3e6f56c0e7a032/pyWinhook-1.6.2.zip
+
+Requires: python3-pywin32
+
+%description
+Python wrapper for out-of-context input hooks in Windows. The pyWinhook package provides callbacks for global mouse and keyboard events in Windows. Python applications register event handlers for user input events such as left mouse down, left mouse up, key down, etc. and set the keyboard and/or mouse hook. The underlying C library reports information like the time of the event, the name of the window in which the event occurred, the value of the event, any keyboard modifiers, etc. pyHook, original project download url: http://www.sourceforge.net/projects/pyhook
+
+
+
+
+%package -n python3-pyWinhook
+Summary: A pyHook module fork from Peter P. with some updates.
+Provides: python-pyWinhook
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+BuildRequires: python3-cffi
+BuildRequires: gcc
+BuildRequires: gdb
+%description -n python3-pyWinhook
+Python wrapper for out-of-context input hooks in Windows. The pyWinhook package provides callbacks for global mouse and keyboard events in Windows. Python applications register event handlers for user input events such as left mouse down, left mouse up, key down, etc. and set the keyboard and/or mouse hook. The underlying C library reports information like the time of the event, the name of the window in which the event occurred, the value of the event, any keyboard modifiers, etc. pyHook, original project download url: http://www.sourceforge.net/projects/pyhook
+
+
+
+
+%package help
+Summary: Development documents and examples for pyWinhook
+Provides: python3-pyWinhook-doc
+%description help
+Python wrapper for out-of-context input hooks in Windows. The pyWinhook package provides callbacks for global mouse and keyboard events in Windows. Python applications register event handlers for user input events such as left mouse down, left mouse up, key down, etc. and set the keyboard and/or mouse hook. The underlying C library reports information like the time of the event, the name of the window in which the event occurred, the value of the event, any keyboard modifiers, etc. pyHook, original project download url: http://www.sourceforge.net/projects/pyhook
+
+
+
+
+%prep
+%autosetup -n pyWinhook-1.6.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pyWinhook -f filelist.lst
+%dir %{python3_sitearch}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 1.6.2-1
+- Package Spec generated