summaryrefslogtreecommitdiff
path: root/python-pywren-ibm-cloud.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-pywren-ibm-cloud.spec')
-rw-r--r--python-pywren-ibm-cloud.spec99
1 files changed, 99 insertions, 0 deletions
diff --git a/python-pywren-ibm-cloud.spec b/python-pywren-ibm-cloud.spec
new file mode 100644
index 0000000..d035e48
--- /dev/null
+++ b/python-pywren-ibm-cloud.spec
@@ -0,0 +1,99 @@
+%global _empty_manifest_terminate_build 0
+Name: python-pywren-ibm-cloud
+Version: 1.7.3
+Release: 1
+Summary: Run many jobs over IBM Cloud
+License: Apache Software License
+URL: https://github.com/pywren/pywren-ibm-cloud
+Source0: https://mirrors.aliyun.com/pypi/web/packages/b5/3a/013430f5c0ac0b854ff842f942c55760f579ca78bba4aeba50fbcb62c937/pywren_ibm_cloud-1.7.3.tar.gz
+BuildArch: noarch
+
+Requires: python3-Click
+Requires: python3-pandas
+Requires: python3-PyYAML
+Requires: python3-dateutil
+Requires: python3-pika
+Requires: python3-enum34
+Requires: python3-glob2
+Requires: python3-tqdm
+Requires: python3-lxml
+Requires: python3-tblib
+Requires: python3-docker
+Requires: python3-requests
+Requires: python3-seaborn
+Requires: python3-paramiko
+Requires: python3-matplotlib
+Requires: python3-kubernetes
+Requires: python3-ibm-cos-sdk
+Requires: python3-gcsfs
+
+%description
+PyWren lets you transparently run your Python functions on IBM Cloud
+
+
+
+
+%package -n python3-pywren-ibm-cloud
+Summary: Run many jobs over IBM Cloud
+Provides: python-pywren-ibm-cloud
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-pywren-ibm-cloud
+PyWren lets you transparently run your Python functions on IBM Cloud
+
+
+
+
+%package help
+Summary: Development documents and examples for pywren-ibm-cloud
+Provides: python3-pywren-ibm-cloud-doc
+%description help
+PyWren lets you transparently run your Python functions on IBM Cloud
+
+
+
+
+%prep
+%autosetup -n pywren_ibm_cloud-1.7.3
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "\"/%h/%f\"\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "\"/%h/%f.gz\"\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-pywren-ibm-cloud -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Tue Jun 20 2023 Python_Bot <Python_Bot@openeuler.org> - 1.7.3-1
+- Package Spec generated