summaryrefslogtreecommitdiff
path: root/python-qsc.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-qsc.spec')
-rw-r--r--python-qsc.spec93
1 files changed, 93 insertions, 0 deletions
diff --git a/python-qsc.spec b/python-qsc.spec
new file mode 100644
index 0000000..9d1d236
--- /dev/null
+++ b/python-qsc.spec
@@ -0,0 +1,93 @@
+%global _empty_manifest_terminate_build 0
+Name: python-qsc
+Version: 0.1.2
+Release: 1
+Summary: Quasisymmetric Stellarator Construction
+License: BSD License
+URL: https://github.com/landreman/pyQSC
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/a1/fe/f8f0e50aa6ad416e04e46d85395ebd6550157c51e90e8591201eebee45ec/qsc-0.1.2.tar.gz
+BuildArch: noarch
+
+
+%description
+# pyQSC
+Python implementation of the Quasisymmetric Stellarator Construction method
+
+This code implements the equations derived by Garren and Boozer (1991) for MHD equilibrium near the magnetic axis.
+
+View the [main documentation here](https://landreman.github.io/pyQSC/)
+
+
+
+%package -n python3-qsc
+Summary: Quasisymmetric Stellarator Construction
+Provides: python-qsc
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-qsc
+# pyQSC
+Python implementation of the Quasisymmetric Stellarator Construction method
+
+This code implements the equations derived by Garren and Boozer (1991) for MHD equilibrium near the magnetic axis.
+
+View the [main documentation here](https://landreman.github.io/pyQSC/)
+
+
+
+%package help
+Summary: Development documents and examples for qsc
+Provides: python3-qsc-doc
+%description help
+# pyQSC
+Python implementation of the Quasisymmetric Stellarator Construction method
+
+This code implements the equations derived by Garren and Boozer (1991) for MHD equilibrium near the magnetic axis.
+
+View the [main documentation here](https://landreman.github.io/pyQSC/)
+
+
+
+%prep
+%autosetup -n qsc-0.1.2
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-qsc -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Thu May 18 2023 Python_Bot <Python_Bot@openeuler.org> - 0.1.2-1
+- Package Spec generated