summaryrefslogtreecommitdiff
path: root/python-qt-pyqt-pyside-custom-widgets.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-qt-pyqt-pyside-custom-widgets.spec')
-rw-r--r--python-qt-pyqt-pyside-custom-widgets.spec327
1 files changed, 327 insertions, 0 deletions
diff --git a/python-qt-pyqt-pyside-custom-widgets.spec b/python-qt-pyqt-pyside-custom-widgets.spec
new file mode 100644
index 0000000..0f87e01
--- /dev/null
+++ b/python-qt-pyqt-pyside-custom-widgets.spec
@@ -0,0 +1,327 @@
+%global _empty_manifest_terminate_build 0
+Name: python-QT-PyQt-PySide-Custom-Widgets
+Version: 0.6.4
+Release: 1
+Summary: Custom widgets and widget animations made for QT applications
+License: GNU General Public License v3.0
+URL: https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/83/8e/a57289d300d9b404fb9f88e471f0dad3115f422a269af8627cc9b3a4dcd9/QT-PyQt-PySide-Custom-Widgets-0.6.4.tar.gz
+BuildArch: noarch
+
+
+%description
+# QT-PyQt-PySide-Custom-Widgets
+Awesome custom widgets made for QT Desktop Applications. Simplify your UI development process. These widgets can be used in QT Designer then imported to PySide code.
+
+# Installation
+First time installer:
+```
+pip install QT-PyQt-PySide-Custom-Widgets
+```
+Upgrade/install the latest version:
+```
+pip install --upgrade QT-PyQt-PySide-Custom-Widgets
+```
+
+# Installation Testing
+Run the following code to see if the installation was successful.
+
+```python
+# Run this from your terminal or create a python file,
+# paste this code, then run
+from Custom_Widgets.ProgressIndicator import test
+test.main()
+```
+
+You should see the following interface:
+![Custom Progress bar](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/Screenshot.png?raw=true)
+
+# How to use it.
+- Read the full documentation plus video guides [here](https://khamisikibet.github.io/QT-PyQt-PySide-Custom-Widgets/)
+
+[Watch the tutorial videos here](https://www.youtube.com/watch?v=21Qt9p_F7Ts&list=PLJ8t3BKaQLhPKj9Mx08WAwvz7TGskefbK)
+
+# What is new?
+## Version 0.6.2:
+- Added support for loading multiple ``JSON Stylesheets``
+ By default, the json file named ``style.json`` will be loaded, so no need to specify. The file must me inside the root directory of your project, ``json`` directory, or ``jsonstyles`` directory inside your project folder for it to be automatically loaded.
+
+ If you have multiple JSON stylesheet files, then you can apply them to your GUI like this:
+ ```python
+ ########################################################################
+ # APPLY JSON STYLESHEET
+ ########################################################################
+ # self = QMainWindow class
+ # self.ui = Ui_MainWindow / user interface class
+ loadJsonStyle(self, self.ui, jsonFiles = {
+ "mystyle.json",
+ "mydirectory/myJsonStyle.json"
+ })
+ ########################################################################
+ ```
+ This feature is helpful especially when you have multiple windows files that will share only some parts of the stylesheet shuch app app title, settings etc.
+
+- Toggle logs:
+ You can now switch app logs on or off.
+ This can be done from a python file:
+ ```python
+ # Show Logs
+ self.showCustomWidgetsLogs = True
+ ```
+ ```python
+ # Hide Logs
+ self.showCustomWidgetsLogs = False
+ ```
+ From the JSON file:
+ ```json
+ {
+ "ShowLogs": true,
+ ```
+ ```json
+ {
+ "ShowLogs": false,
+ ```
+
+# Sample Images
+
+Analog Gauge Widget
+
+![Analog Gauge Widget](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/analog_qt_widget.png?raw=true)
+
+Responsive Animated GUI
+
+![Resposive PyQt PySide GUI](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/responsive-qt-gui-python-intarface.png?raw=true)
+
+Animated QStacked Widget
+
+![Custom QStacked Widgets](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/qstacked.png?raw=true)
+
+
+%package -n python3-QT-PyQt-PySide-Custom-Widgets
+Summary: Custom widgets and widget animations made for QT applications
+Provides: python-QT-PyQt-PySide-Custom-Widgets
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-QT-PyQt-PySide-Custom-Widgets
+# QT-PyQt-PySide-Custom-Widgets
+Awesome custom widgets made for QT Desktop Applications. Simplify your UI development process. These widgets can be used in QT Designer then imported to PySide code.
+
+# Installation
+First time installer:
+```
+pip install QT-PyQt-PySide-Custom-Widgets
+```
+Upgrade/install the latest version:
+```
+pip install --upgrade QT-PyQt-PySide-Custom-Widgets
+```
+
+# Installation Testing
+Run the following code to see if the installation was successful.
+
+```python
+# Run this from your terminal or create a python file,
+# paste this code, then run
+from Custom_Widgets.ProgressIndicator import test
+test.main()
+```
+
+You should see the following interface:
+![Custom Progress bar](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/Screenshot.png?raw=true)
+
+# How to use it.
+- Read the full documentation plus video guides [here](https://khamisikibet.github.io/QT-PyQt-PySide-Custom-Widgets/)
+
+[Watch the tutorial videos here](https://www.youtube.com/watch?v=21Qt9p_F7Ts&list=PLJ8t3BKaQLhPKj9Mx08WAwvz7TGskefbK)
+
+# What is new?
+## Version 0.6.2:
+- Added support for loading multiple ``JSON Stylesheets``
+ By default, the json file named ``style.json`` will be loaded, so no need to specify. The file must me inside the root directory of your project, ``json`` directory, or ``jsonstyles`` directory inside your project folder for it to be automatically loaded.
+
+ If you have multiple JSON stylesheet files, then you can apply them to your GUI like this:
+ ```python
+ ########################################################################
+ # APPLY JSON STYLESHEET
+ ########################################################################
+ # self = QMainWindow class
+ # self.ui = Ui_MainWindow / user interface class
+ loadJsonStyle(self, self.ui, jsonFiles = {
+ "mystyle.json",
+ "mydirectory/myJsonStyle.json"
+ })
+ ########################################################################
+ ```
+ This feature is helpful especially when you have multiple windows files that will share only some parts of the stylesheet shuch app app title, settings etc.
+
+- Toggle logs:
+ You can now switch app logs on or off.
+ This can be done from a python file:
+ ```python
+ # Show Logs
+ self.showCustomWidgetsLogs = True
+ ```
+ ```python
+ # Hide Logs
+ self.showCustomWidgetsLogs = False
+ ```
+ From the JSON file:
+ ```json
+ {
+ "ShowLogs": true,
+ ```
+ ```json
+ {
+ "ShowLogs": false,
+ ```
+
+# Sample Images
+
+Analog Gauge Widget
+
+![Analog Gauge Widget](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/analog_qt_widget.png?raw=true)
+
+Responsive Animated GUI
+
+![Resposive PyQt PySide GUI](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/responsive-qt-gui-python-intarface.png?raw=true)
+
+Animated QStacked Widget
+
+![Custom QStacked Widgets](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/qstacked.png?raw=true)
+
+
+%package help
+Summary: Development documents and examples for QT-PyQt-PySide-Custom-Widgets
+Provides: python3-QT-PyQt-PySide-Custom-Widgets-doc
+%description help
+# QT-PyQt-PySide-Custom-Widgets
+Awesome custom widgets made for QT Desktop Applications. Simplify your UI development process. These widgets can be used in QT Designer then imported to PySide code.
+
+# Installation
+First time installer:
+```
+pip install QT-PyQt-PySide-Custom-Widgets
+```
+Upgrade/install the latest version:
+```
+pip install --upgrade QT-PyQt-PySide-Custom-Widgets
+```
+
+# Installation Testing
+Run the following code to see if the installation was successful.
+
+```python
+# Run this from your terminal or create a python file,
+# paste this code, then run
+from Custom_Widgets.ProgressIndicator import test
+test.main()
+```
+
+You should see the following interface:
+![Custom Progress bar](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/Screenshot.png?raw=true)
+
+# How to use it.
+- Read the full documentation plus video guides [here](https://khamisikibet.github.io/QT-PyQt-PySide-Custom-Widgets/)
+
+[Watch the tutorial videos here](https://www.youtube.com/watch?v=21Qt9p_F7Ts&list=PLJ8t3BKaQLhPKj9Mx08WAwvz7TGskefbK)
+
+# What is new?
+## Version 0.6.2:
+- Added support for loading multiple ``JSON Stylesheets``
+ By default, the json file named ``style.json`` will be loaded, so no need to specify. The file must me inside the root directory of your project, ``json`` directory, or ``jsonstyles`` directory inside your project folder for it to be automatically loaded.
+
+ If you have multiple JSON stylesheet files, then you can apply them to your GUI like this:
+ ```python
+ ########################################################################
+ # APPLY JSON STYLESHEET
+ ########################################################################
+ # self = QMainWindow class
+ # self.ui = Ui_MainWindow / user interface class
+ loadJsonStyle(self, self.ui, jsonFiles = {
+ "mystyle.json",
+ "mydirectory/myJsonStyle.json"
+ })
+ ########################################################################
+ ```
+ This feature is helpful especially when you have multiple windows files that will share only some parts of the stylesheet shuch app app title, settings etc.
+
+- Toggle logs:
+ You can now switch app logs on or off.
+ This can be done from a python file:
+ ```python
+ # Show Logs
+ self.showCustomWidgetsLogs = True
+ ```
+ ```python
+ # Hide Logs
+ self.showCustomWidgetsLogs = False
+ ```
+ From the JSON file:
+ ```json
+ {
+ "ShowLogs": true,
+ ```
+ ```json
+ {
+ "ShowLogs": false,
+ ```
+
+# Sample Images
+
+Analog Gauge Widget
+
+![Analog Gauge Widget](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/analog_qt_widget.png?raw=true)
+
+Responsive Animated GUI
+
+![Resposive PyQt PySide GUI](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/responsive-qt-gui-python-intarface.png?raw=true)
+
+Animated QStacked Widget
+
+![Custom QStacked Widgets](https://github.com/KhamisiKibet/QT-PyQt-PySide-Custom-Widgets/blob/main/images/qstacked.png?raw=true)
+
+
+%prep
+%autosetup -n QT-PyQt-PySide-Custom-Widgets-0.6.4
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-QT-PyQt-PySide-Custom-Widgets -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.6.4-1
+- Package Spec generated