summaryrefslogtreecommitdiff
path: root/python-qtile.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-qtile.spec')
-rw-r--r--python-qtile.spec114
1 files changed, 114 insertions, 0 deletions
diff --git a/python-qtile.spec b/python-qtile.spec
new file mode 100644
index 0000000..3b6da6a
--- /dev/null
+++ b/python-qtile.spec
@@ -0,0 +1,114 @@
+%global _empty_manifest_terminate_build 0
+Name: python-qtile
+Version: 0.22.1
+Release: 1
+Summary: A pure-Python tiling window manager.
+License: MIT
+URL: https://qtile.org
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/c5/6d/662b20c4f19e4c68e44564e4c5b51e41d477722cfacfaa178acb548c40f2/qtile-0.22.1.tar.gz
+BuildArch: noarch
+
+Requires: python3-cffi
+Requires: python3-cairocffi[xcb]
+Requires: python3-xcffib
+Requires: python3-sphinx
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinxcontrib-seqdiag
+Requires: python3-numpydoc
+Requires: python3-ipykernel
+Requires: python3-jupyter-console
+Requires: python3-flake8
+Requires: python3-pep8-naming
+Requires: python3-pytest-cov
+Requires: python3-pywayland
+Requires: python3-pywlroots
+Requires: python3-xkbcommon
+
+%description
+* Simple, small and extensible. It's easy to write your own layouts,
+ widgets and commands.
+* Configured in Python.
+* Runs as an X11 WM or a Wayland compositor.
+* Command shell that allows all aspects of Qtile to be managed and
+ inspected.
+* Complete remote scriptability - write scripts to set up workspaces,
+ manipulate windows, update status bar widgets and more.
+* Qtile's remote scriptability makes it one of the most thoroughly
+ unit-tested window managers around.
+
+%package -n python3-qtile
+Summary: A pure-Python tiling window manager.
+Provides: python-qtile
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-qtile
+* Simple, small and extensible. It's easy to write your own layouts,
+ widgets and commands.
+* Configured in Python.
+* Runs as an X11 WM or a Wayland compositor.
+* Command shell that allows all aspects of Qtile to be managed and
+ inspected.
+* Complete remote scriptability - write scripts to set up workspaces,
+ manipulate windows, update status bar widgets and more.
+* Qtile's remote scriptability makes it one of the most thoroughly
+ unit-tested window managers around.
+
+%package help
+Summary: Development documents and examples for qtile
+Provides: python3-qtile-doc
+%description help
+* Simple, small and extensible. It's easy to write your own layouts,
+ widgets and commands.
+* Configured in Python.
+* Runs as an X11 WM or a Wayland compositor.
+* Command shell that allows all aspects of Qtile to be managed and
+ inspected.
+* Complete remote scriptability - write scripts to set up workspaces,
+ manipulate windows, update status bar widgets and more.
+* Qtile's remote scriptability makes it one of the most thoroughly
+ unit-tested window managers around.
+
+%prep
+%autosetup -n qtile-0.22.1
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-qtile -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 17 2023 Python_Bot <Python_Bot@openeuler.org> - 0.22.1-1
+- Package Spec generated