summaryrefslogtreecommitdiff
path: root/python-quantify-scheduler.spec
diff options
context:
space:
mode:
Diffstat (limited to 'python-quantify-scheduler.spec')
-rw-r--r--python-quantify-scheduler.spec272
1 files changed, 272 insertions, 0 deletions
diff --git a/python-quantify-scheduler.spec b/python-quantify-scheduler.spec
new file mode 100644
index 0000000..4387c66
--- /dev/null
+++ b/python-quantify-scheduler.spec
@@ -0,0 +1,272 @@
+%global _empty_manifest_terminate_build 0
+Name: python-quantify-scheduler
+Version: 0.13.0
+Release: 1
+Summary: Quantify-scheduler is a Python package for writing quantum programs featuring a hybrid gate-pulse control model with explicit timing control.
+License: BSD-3-Clause
+URL: https://pypi.org/project/quantify-scheduler/
+Source0: https://mirrors.nju.edu.cn/pypi/web/packages/74/a5/34ff3486d20edb88c2c6962a7be80b0aa41530873274dff58ec60f309052/quantify-scheduler-0.13.0.tar.gz
+BuildArch: noarch
+
+Requires: python3-columnar
+Requires: python3-dataclasses-json
+Requires: python3-fastjsonschema
+Requires: python3-matplotlib
+Requires: python3-networkx
+Requires: python3-numpy
+Requires: python3-orjson
+Requires: python3-pandas[output_formatting]
+Requires: python3-pathvalidate
+Requires: python3-plotly
+Requires: python3-pydantic
+Requires: python3-qblox-instruments
+Requires: python3-quantify-core
+Requires: python3-qcodes
+Requires: python3-scipy
+Requires: python3-xxhash
+Requires: python3-zhinst
+Requires: python3-zhinst-qcodes
+Requires: python3-zhinst-toolkit
+Requires: python3-rich[jupyter]
+Requires: python3-black
+Requires: python3-coverage
+Requires: python3-pre-commit
+Requires: python3-pre-commit-hooks
+Requires: python3-prospector
+Requires: python3-pylint
+Requires: python3-pyright
+Requires: python3-pytest-cov
+Requires: python3-pytest-xdist
+Requires: python3-ruff
+Requires: python3-quantify-scheduler[docs,test]
+Requires: python3-qblox-instruments
+Requires: python3-jupyter-sphinx
+Requires: python3-jupytext
+Requires: python3-myst-nb
+Requires: python3-rich[jupyter]
+Requires: python3-scanpydoc
+Requires: python3-sphinx-autoapi
+Requires: python3-sphinx-autobuild
+Requires: python3-sphinx-autodoc-typehints
+Requires: python3-sphinx-jsonschema
+Requires: python3-sphinx-rtd-theme
+Requires: python3-sphinx-togglebutton
+Requires: python3-sphinx
+Requires: python3-sphinxcontrib-bibtex
+Requires: python3-pytest
+Requires: python3-pytest-mock
+
+%description
+# quantify-scheduler
+
+[![Slack](https://img.shields.io/badge/slack-chat-green.svg)](https://quantify-os.org/slack.html#sec-slack)
+[![Pipelines](https://gitlab.com/quantify-os/quantify-scheduler/badges/main/pipeline.svg)](https://gitlab.com/quantify-os/quantify-scheduler/-/pipelines/)
+[![PyPi](https://img.shields.io/pypi/v/quantify-scheduler.svg)](https://pypi.org/project/quantify-scheduler)
+[![Code Quality](https://app.codacy.com/project/badge/Grade/0c9cf5b6eb5f47ffbd2bb484d555c7e3)](https://www.codacy.com/gl/quantify-os/quantify-scheduler/dashboard?utm_source=gitlab.com&utm_medium=referral&utm_content=quantify-os/quantify-scheduler&utm_campaign=Badge_Grade)
+[![Coverage](https://app.codacy.com/project/badge/Coverage/0c9cf5b6eb5f47ffbd2bb484d555c7e3)](https://www.codacy.com/gl/quantify-os/quantify-scheduler/dashboard?utm_source=gitlab.com&utm_medium=referral&utm_content=quantify-os/quantify-scheduler&utm_campaign=Badge_Coverage)
+[![Documentation Status](https://readthedocs.com/projects/quantify-quantify-scheduler/badge/?version=latest)](https://quantify-quantify-scheduler.readthedocs-hosted.com)
+[![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg)](https://gitlab.com/quantify-os/quantify-scheduler/-/raw/main/LICENSE)
+[![Code style](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![Unitary Fund](https://img.shields.io/badge/Supported%20By-UNITARY%20FUND-brightgreen.svg?style=flat)](https://unitary.fund)
+
+![Quantify logo](https://orangeqs.com/logos/QUANTIFY_LANDSCAPE.svg)
+
+Quantify is a Python-based data acquisition framework focused on Quantum Computing and
+solid-state physics experiments.
+The framework consists of [quantify-core](https://pypi.org/project/quantify-core/) ([git repo](https://gitlab.com/quantify-os/quantify-core/))
+and [quantify-scheduler](https://pypi.org/project/quantify-scheduler/) ([git repo](https://gitlab.com/quantify-os/quantify-scheduler/)).
+It is built on top of [QCoDeS](https://qcodes.github.io/Qcodes/)
+and is a spiritual successor of [PycQED](https://github.com/DiCarloLab-Delft/PycQED_py3).
+
+`quantify-scheduler` is a Python module for writing quantum programs featuring a hybrid gate-pulse control model with explicit timing control.
+This control model allows quantum gate and pulse-level descriptions to be combined in a clearly defined and hardware-agnostic way.
+`quantify-scheduler` is designed to allow experimentalists to easily define complex experiments. It produces synchronized pulse schedules
+that are distributed to control hardware, after compiling these schedules into control-hardware specific executable programs.
+
+Take a look at the [latest documentation for quantify-scheduler](https://quantify-quantify-scheduler.readthedocs-hosted.com/)
+or use the switch at the bottom of the left panel to read the documentation for older releases.
+Also see the [latest documentation for quantify-core](https://quantify-quantify-core.readthedocs-hosted.com/).
+
+## Hardware/driver compatibility
+
+- Qblox: `qblox-instruments==0.9.0` ([Cluster firmware v0.4.0](https://gitlab.com/qblox/releases/cluster_releases/-/releases/v0.4.0)) and `qblox-instruments==0.10.x` ([Cluster firmware v0.5.0](https://gitlab.com/qblox/releases/cluster_releases/-/releases/v0.5.0))
+- ZI: `zhinst==21.8.20515` `zhinst-qcodes==0.1.4` `zhinst-toolkit==0.1.5`
+
+
+## Overview and Community
+
+For a general overview of Quantify and connecting to its open-source community, see [quantify-os.org](https://quantify-os.org/).
+Quantify is maintained by the Quantify Consortium consisting of Qblox and Orange Quantum Systems.
+
+[<img src="https://cdn.sanity.io/images/ostxzp7d/production/f9ab429fc72aea1b31c4b2c7fab5e378b67d75c3-132x31.svg" alt="Qblox logo" width=200px/>](https://www.qblox.com)
+&nbsp;
+&nbsp;
+&nbsp;
+&nbsp;
+[<img src="https://orangeqs.com/OQS_logo_with_text.svg" alt="Orange Quantum Systems logo" width=200px/>](https://orangeqs.com)
+
+&nbsp;
+
+The software is free to use under the conditions specified in the [license](https://gitlab.com/quantify-os/quantify-scheduler/-/raw/main/LICENSE).
+
+
+%package -n python3-quantify-scheduler
+Summary: Quantify-scheduler is a Python package for writing quantum programs featuring a hybrid gate-pulse control model with explicit timing control.
+Provides: python-quantify-scheduler
+BuildRequires: python3-devel
+BuildRequires: python3-setuptools
+BuildRequires: python3-pip
+%description -n python3-quantify-scheduler
+# quantify-scheduler
+
+[![Slack](https://img.shields.io/badge/slack-chat-green.svg)](https://quantify-os.org/slack.html#sec-slack)
+[![Pipelines](https://gitlab.com/quantify-os/quantify-scheduler/badges/main/pipeline.svg)](https://gitlab.com/quantify-os/quantify-scheduler/-/pipelines/)
+[![PyPi](https://img.shields.io/pypi/v/quantify-scheduler.svg)](https://pypi.org/project/quantify-scheduler)
+[![Code Quality](https://app.codacy.com/project/badge/Grade/0c9cf5b6eb5f47ffbd2bb484d555c7e3)](https://www.codacy.com/gl/quantify-os/quantify-scheduler/dashboard?utm_source=gitlab.com&amp;utm_medium=referral&amp;utm_content=quantify-os/quantify-scheduler&amp;utm_campaign=Badge_Grade)
+[![Coverage](https://app.codacy.com/project/badge/Coverage/0c9cf5b6eb5f47ffbd2bb484d555c7e3)](https://www.codacy.com/gl/quantify-os/quantify-scheduler/dashboard?utm_source=gitlab.com&amp;utm_medium=referral&amp;utm_content=quantify-os/quantify-scheduler&amp;utm_campaign=Badge_Coverage)
+[![Documentation Status](https://readthedocs.com/projects/quantify-quantify-scheduler/badge/?version=latest)](https://quantify-quantify-scheduler.readthedocs-hosted.com)
+[![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg)](https://gitlab.com/quantify-os/quantify-scheduler/-/raw/main/LICENSE)
+[![Code style](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![Unitary Fund](https://img.shields.io/badge/Supported%20By-UNITARY%20FUND-brightgreen.svg?style=flat)](https://unitary.fund)
+
+![Quantify logo](https://orangeqs.com/logos/QUANTIFY_LANDSCAPE.svg)
+
+Quantify is a Python-based data acquisition framework focused on Quantum Computing and
+solid-state physics experiments.
+The framework consists of [quantify-core](https://pypi.org/project/quantify-core/) ([git repo](https://gitlab.com/quantify-os/quantify-core/))
+and [quantify-scheduler](https://pypi.org/project/quantify-scheduler/) ([git repo](https://gitlab.com/quantify-os/quantify-scheduler/)).
+It is built on top of [QCoDeS](https://qcodes.github.io/Qcodes/)
+and is a spiritual successor of [PycQED](https://github.com/DiCarloLab-Delft/PycQED_py3).
+
+`quantify-scheduler` is a Python module for writing quantum programs featuring a hybrid gate-pulse control model with explicit timing control.
+This control model allows quantum gate and pulse-level descriptions to be combined in a clearly defined and hardware-agnostic way.
+`quantify-scheduler` is designed to allow experimentalists to easily define complex experiments. It produces synchronized pulse schedules
+that are distributed to control hardware, after compiling these schedules into control-hardware specific executable programs.
+
+Take a look at the [latest documentation for quantify-scheduler](https://quantify-quantify-scheduler.readthedocs-hosted.com/)
+or use the switch at the bottom of the left panel to read the documentation for older releases.
+Also see the [latest documentation for quantify-core](https://quantify-quantify-core.readthedocs-hosted.com/).
+
+## Hardware/driver compatibility
+
+- Qblox: `qblox-instruments==0.9.0` ([Cluster firmware v0.4.0](https://gitlab.com/qblox/releases/cluster_releases/-/releases/v0.4.0)) and `qblox-instruments==0.10.x` ([Cluster firmware v0.5.0](https://gitlab.com/qblox/releases/cluster_releases/-/releases/v0.5.0))
+- ZI: `zhinst==21.8.20515` `zhinst-qcodes==0.1.4` `zhinst-toolkit==0.1.5`
+
+
+## Overview and Community
+
+For a general overview of Quantify and connecting to its open-source community, see [quantify-os.org](https://quantify-os.org/).
+Quantify is maintained by the Quantify Consortium consisting of Qblox and Orange Quantum Systems.
+
+[<img src="https://cdn.sanity.io/images/ostxzp7d/production/f9ab429fc72aea1b31c4b2c7fab5e378b67d75c3-132x31.svg" alt="Qblox logo" width=200px/>](https://www.qblox.com)
+&nbsp;
+&nbsp;
+&nbsp;
+&nbsp;
+[<img src="https://orangeqs.com/OQS_logo_with_text.svg" alt="Orange Quantum Systems logo" width=200px/>](https://orangeqs.com)
+
+&nbsp;
+
+The software is free to use under the conditions specified in the [license](https://gitlab.com/quantify-os/quantify-scheduler/-/raw/main/LICENSE).
+
+
+%package help
+Summary: Development documents and examples for quantify-scheduler
+Provides: python3-quantify-scheduler-doc
+%description help
+# quantify-scheduler
+
+[![Slack](https://img.shields.io/badge/slack-chat-green.svg)](https://quantify-os.org/slack.html#sec-slack)
+[![Pipelines](https://gitlab.com/quantify-os/quantify-scheduler/badges/main/pipeline.svg)](https://gitlab.com/quantify-os/quantify-scheduler/-/pipelines/)
+[![PyPi](https://img.shields.io/pypi/v/quantify-scheduler.svg)](https://pypi.org/project/quantify-scheduler)
+[![Code Quality](https://app.codacy.com/project/badge/Grade/0c9cf5b6eb5f47ffbd2bb484d555c7e3)](https://www.codacy.com/gl/quantify-os/quantify-scheduler/dashboard?utm_source=gitlab.com&amp;utm_medium=referral&amp;utm_content=quantify-os/quantify-scheduler&amp;utm_campaign=Badge_Grade)
+[![Coverage](https://app.codacy.com/project/badge/Coverage/0c9cf5b6eb5f47ffbd2bb484d555c7e3)](https://www.codacy.com/gl/quantify-os/quantify-scheduler/dashboard?utm_source=gitlab.com&amp;utm_medium=referral&amp;utm_content=quantify-os/quantify-scheduler&amp;utm_campaign=Badge_Coverage)
+[![Documentation Status](https://readthedocs.com/projects/quantify-quantify-scheduler/badge/?version=latest)](https://quantify-quantify-scheduler.readthedocs-hosted.com)
+[![License](https://img.shields.io/badge/License-BSD%203--Clause-blue.svg)](https://gitlab.com/quantify-os/quantify-scheduler/-/raw/main/LICENSE)
+[![Code style](https://img.shields.io/badge/code%20style-black-000000.svg)](https://github.com/psf/black)
+[![Unitary Fund](https://img.shields.io/badge/Supported%20By-UNITARY%20FUND-brightgreen.svg?style=flat)](https://unitary.fund)
+
+![Quantify logo](https://orangeqs.com/logos/QUANTIFY_LANDSCAPE.svg)
+
+Quantify is a Python-based data acquisition framework focused on Quantum Computing and
+solid-state physics experiments.
+The framework consists of [quantify-core](https://pypi.org/project/quantify-core/) ([git repo](https://gitlab.com/quantify-os/quantify-core/))
+and [quantify-scheduler](https://pypi.org/project/quantify-scheduler/) ([git repo](https://gitlab.com/quantify-os/quantify-scheduler/)).
+It is built on top of [QCoDeS](https://qcodes.github.io/Qcodes/)
+and is a spiritual successor of [PycQED](https://github.com/DiCarloLab-Delft/PycQED_py3).
+
+`quantify-scheduler` is a Python module for writing quantum programs featuring a hybrid gate-pulse control model with explicit timing control.
+This control model allows quantum gate and pulse-level descriptions to be combined in a clearly defined and hardware-agnostic way.
+`quantify-scheduler` is designed to allow experimentalists to easily define complex experiments. It produces synchronized pulse schedules
+that are distributed to control hardware, after compiling these schedules into control-hardware specific executable programs.
+
+Take a look at the [latest documentation for quantify-scheduler](https://quantify-quantify-scheduler.readthedocs-hosted.com/)
+or use the switch at the bottom of the left panel to read the documentation for older releases.
+Also see the [latest documentation for quantify-core](https://quantify-quantify-core.readthedocs-hosted.com/).
+
+## Hardware/driver compatibility
+
+- Qblox: `qblox-instruments==0.9.0` ([Cluster firmware v0.4.0](https://gitlab.com/qblox/releases/cluster_releases/-/releases/v0.4.0)) and `qblox-instruments==0.10.x` ([Cluster firmware v0.5.0](https://gitlab.com/qblox/releases/cluster_releases/-/releases/v0.5.0))
+- ZI: `zhinst==21.8.20515` `zhinst-qcodes==0.1.4` `zhinst-toolkit==0.1.5`
+
+
+## Overview and Community
+
+For a general overview of Quantify and connecting to its open-source community, see [quantify-os.org](https://quantify-os.org/).
+Quantify is maintained by the Quantify Consortium consisting of Qblox and Orange Quantum Systems.
+
+[<img src="https://cdn.sanity.io/images/ostxzp7d/production/f9ab429fc72aea1b31c4b2c7fab5e378b67d75c3-132x31.svg" alt="Qblox logo" width=200px/>](https://www.qblox.com)
+&nbsp;
+&nbsp;
+&nbsp;
+&nbsp;
+[<img src="https://orangeqs.com/OQS_logo_with_text.svg" alt="Orange Quantum Systems logo" width=200px/>](https://orangeqs.com)
+
+&nbsp;
+
+The software is free to use under the conditions specified in the [license](https://gitlab.com/quantify-os/quantify-scheduler/-/raw/main/LICENSE).
+
+
+%prep
+%autosetup -n quantify-scheduler-0.13.0
+
+%build
+%py3_build
+
+%install
+%py3_install
+install -d -m755 %{buildroot}/%{_pkgdocdir}
+if [ -d doc ]; then cp -arf doc %{buildroot}/%{_pkgdocdir}; fi
+if [ -d docs ]; then cp -arf docs %{buildroot}/%{_pkgdocdir}; fi
+if [ -d example ]; then cp -arf example %{buildroot}/%{_pkgdocdir}; fi
+if [ -d examples ]; then cp -arf examples %{buildroot}/%{_pkgdocdir}; fi
+pushd %{buildroot}
+if [ -d usr/lib ]; then
+ find usr/lib -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/lib64 ]; then
+ find usr/lib64 -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/bin ]; then
+ find usr/bin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+if [ -d usr/sbin ]; then
+ find usr/sbin -type f -printf "/%h/%f\n" >> filelist.lst
+fi
+touch doclist.lst
+if [ -d usr/share/man ]; then
+ find usr/share/man -type f -printf "/%h/%f.gz\n" >> doclist.lst
+fi
+popd
+mv %{buildroot}/filelist.lst .
+mv %{buildroot}/doclist.lst .
+
+%files -n python3-quantify-scheduler -f filelist.lst
+%dir %{python3_sitelib}/*
+
+%files help -f doclist.lst
+%{_docdir}/*
+
+%changelog
+* Wed May 31 2023 Python_Bot <Python_Bot@openeuler.org> - 0.13.0-1
+- Package Spec generated